It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I'm stuck at the Mill Management Arsenic Shipment board. As in, I think that the game has bugged.

I had already worked out that the puzzle solution was either "New Jersey" or "USA" as the destination, with "MON 16" as the date,but neither solution worked so I assumed that I was missing something. Finally, unable to figure out where I went wrong, I consulted a guide, but it turns out that I was correct all along. Unfortunately, entering the correct information triggered nothing. No dialog played, and the projecter remains incomplete. As far as I can tell, I have finished everything else in the area.

Has anyone else run into this? Might I have missed something obscure? I have already opened the safe.
Hey I thought I had the same problem as you, turns out, that I just confused "DATE" and "DAY". Maybe you confused it either? If not, I hope you'll find another solution. Good luck!