It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
avatar
b1inky: Okay, we're making progress! DOSBox staging, output=texturepp and texture_renderer=opengl. Forced vsync through NVIDIA control panel for the program. The game runs fine now when you're actually playing (which is great!), however with these settings the music skips in the menus, along with the menu screen stuttering in general. But we're getting closer...lol
avatar
Crimson_T: Glad to hear that some progress is being made! I'm not sure how you've set some of the options, but with output=texturepp, all other scaling options should be disabled as it can interfere with how the pixel perfect scaling mode works. That could add a bit of lag if some are enabled. So to be clear the following should be set like this:

fullresolution = desktop
aspect =false
scaler = none
glshader = none
avatar
Crimson_T: You could also try playing with the settings in the [mixer] section, "blocksize" specifically.

As for the VSYNC messing other games.... You had mentioned trying different DOSBox builds, did you try the DOSBox X one I mentioned previously? The VSYNC is built in, so that you wouldn't need to force it. Also you can get the pixel perfect mode through an OpenGL Shader, and I've updated that guide to reflect this.
I tried DOSBox X once before, the reason I switched to Staging is because pixel perfect mode is important to me. I wasn't aware DOSBox X had it, I'll check it out--thanks!
avatar
b1inky: Okay, we're making progress! DOSBox staging, output=texturepp and texture_renderer=opengl. Forced vsync through NVIDIA control panel for the program. The game runs fine now when you're actually playing (which is great!), however with these settings the music skips in the menus, along with the menu screen stuttering in general. But we're getting closer...lol
avatar
Crimson_T: Glad to hear that some progress is being made! I'm not sure how you've set some of the options, but with output=texturepp, all other scaling options should be disabled as it can interfere with how the pixel perfect scaling mode works. That could add a bit of lag if some are enabled. So to be clear the following should be set like this:

fullresolution = desktop
aspect =false
scaler = none
glshader = none
avatar
Crimson_T: You could also try playing with the settings in the [mixer] section, "blocksize" specifically.

As for the VSYNC messing other games.... You had mentioned trying different DOSBox builds, did you try the DOSBox X one I mentioned previously? The VSYNC is built in, so that you wouldn't need to force it. Also you can get the pixel perfect mode through an OpenGL Shader, and I've updated that guide to reflect this.

EDIT: The only other thing I can think of is running the setup.exe through DOSBox and making sure that the PORT,IRQ,DMA for your audio choice all match what in the "dosbox_epin.conf"
Looks like this did it! I should have just gone to your guide to begin with, but I was set on sticking with Staging.

DOSBox X, with the pixel perfect shader and vsync enabled through the DOSBox X config and its as smooth as butter. Thank you!

Thanks TheBigCore for your help too.