It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I just bought and booted this up. I spent SO MUCH TIME with the demo in late grade school and early Jr. High. Memories!

However, there's some nasty input lag on the flippers. I don't think it's the display as other things don't have that. Is it just the way this game is or is there something to be done in DOS Box to help with that? It's been a long while since I messed with DOS Box stuff.

Thanks in advance!
avatar
daroga: I just bought and booted this up. I spent SO MUCH TIME with the demo in late grade school and early Jr. High. Memories!

However, there's some nasty input lag on the flippers. I don't think it's the display as other things don't have that. Is it just the way this game is or is there something to be done in DOS Box to help with that? It's been a long while since I messed with DOS Box stuff.

Thanks in advance!
You can try altering the frameskip=0 value to 1 in dosbox_epin.conf config file.

Good luck!
Yeah usually gog's dosbox configurations suck balls with too many soundbuffers and blocks, but I don't think it can be solved by turning on frameskipping.

https://www.gog.com/forum/epic_pinball_the_complete_collection/alternative_dosbox_configuration/post1

I made a .conf for you to try out if you want but I haven't tested it since I don't have the game (yet), so make a backup of the original dosbox_epicpin.conf.
Post edited December 25, 2018 by Strijkbout
avatar
Strijkbout: Yeah usually gog's dosbox configurations suck balls with too many soundbuffers and blocks, but I don't think it can be solved by turning on frameskipping.

I made a .conf for you to try out if you want but I haven't tested it since I don't have the game (yet), so make a backup of the original dosbox_epicpin.conf.

https://drive.google.com/file/d/1LNUfmMfcb48FMQ5MshvIWLYOxngQFdaR/view?usp=sharing
Thank you for trying this! I really appreciate it!

In practice, the only thing I noticed different about this config is that the menus were way slower. Maybe as you or others get the game, if they run into the same problem, someone will come up with a solution.

I'm going to try it on my laptop tomorrow and see how it goes.

Thanks!
I made some changes, cycles=10000 and refreshed the download link.

I have Jazz Jackrabbit on cdrom, it should contain the shareware version of Epic Pinball.
When I can bring myself to it I will test some configurations.

edit:

Okay, I've tested it on the shareware version and on my system it runs fine.
I've setup the game for Soundblaster 16 on a Pentium system, I don't know what the settings are gog uses.
The only thing to keep in mind is not to use opengl or openglnb because then the sound will stutter, just use ddraw (nice) or overlay (less nice).
There is a littlebit of screentearing but nothing I can't live with, AFAIK this is a shortcoming of dosbox at the moment and I don't think that can easily be solved.
Post edited December 25, 2018 by Strijkbout
avatar
Strijkbout: I've setup the game for Soundblaster 16 on a Pentium system, I don't know what the settings are gog uses.
Here are the default settings from the GOG .conf file if that helps:

[sdl]
fullscreen=true
fulldouble=true
fullresolution=desktop
windowresolution=original
output=overlay
autolock=true
sensitivity=100
waitonerror=true
priority=higher,normal
mapperfile=mapper-0.74.map
usescancodes=true

[dosbox]
language=
machine=svga_s3
captures=capture
memsize=16

[render]
frameskip=0
aspect=true
scaler=normal2x

[cpu]
core=auto
cputype=auto
cycles=max
cycleup=1000
cycledown=1000

[mixer]
nosound=false
rate=44100
blocksize=1024
prebuffer=80

[midi]
mpu401=intelligent
mididevice=default
midiconfig=

[sblaster]
sbtype=sb16
sbbase=220
irq=7
dma=1
hdma=5
sbmixer=true
oplmode=auto
oplemu=default
oplrate=44100

[gus] (who's he? :P)
gus=false
gusrate=44100
gusbase=240
gusirq=5
gusdma=3
ultradir=C:\ULTRASND

[speaker]
pcspeaker=true
pcrate=44100
tandy=auto
tandyrate=44100
disney=true

[joystick]
joysticktype=auto
timed=true
autofire=false
swap34=false
buttonwrap=false

[serial]
serial1=dummy
serial2=dummy
serial3=disabled
serial4=disabled

[dos]
xms=true
ems=true
umb=true
keyboardlayout=auto
Post edited December 03, 2017 by RetroCodger426
avatar
RetroCodger426: Here are the default settings from the GOG .conf file if that helps:
Thanks for posting this!

It seems differences are minimal, though prebuffer are 4x higher than standard dosbox values, probably to allow for opengl output, but this gives the game more lag.
Also fulldouble=true may make the game less responsive.
avatar
RetroCodger426: Here are the default settings from the GOG .conf file if that helps:
avatar
Strijkbout: Thanks for posting this!

It seems differences are minimal, though prebuffer are 4x higher than standard dosbox values, probably to allow for opengl output, but this gives the game more lag.
Also fulldouble=true may make the game less responsive.
No problem, and thank you for your efforts making the custom .conf file :)
Yep, I'm a DosBox novice and even I've learned a long time ago that these settings always need a good bit of tweaking.
After buying Epic Pinball and Jazz 1 & 2, it's been a learning curve. After a few frustrating hours working with custom DOSBox builds I'm slowly learning, so that's not a bad thing I suppose. Just wish GOG would use the best versions of DOSBox and tweak them a bit better. We, the buyers shouldn't have to do all of this really. A few tweaks here and there, sure, fine, but some games are almost broken 'out of the box'.

*Edit* actually, I'm exaggerating there a little. I've had very little trouble with DOSBox on GOG besides the mandatory tweaks, but Jazz Jackrabbit has driven me to insanity! :D
Post edited December 03, 2017 by RetroCodger426
avatar
RetroCodger426: *Edit* actually, I'm exaggerating there a little. I've had very little trouble with DOSBox on GOG besides the mandatory tweaks, but Jazz Jackrabbit has driven me to insanity! :D
I've made one for Jazz Jackrabbit as well. :^)

https://www.gog.com/forum/jazz_jackrabbit/jazz_1_low_framerate/post14
avatar
RetroCodger426: *Edit* actually, I'm exaggerating there a little. I've had very little trouble with DOSBox on GOG besides the mandatory tweaks, but Jazz Jackrabbit has driven me to insanity! :D
avatar
Strijkbout: I've made one for Jazz Jackrabbit as well. :^)

https://www.gog.com/forum/jazz_jackrabbit/jazz_1_low_framerate/post14
Thanks very much! I'll try it.
This is how my dosbox_epin.conf looks, no input lag, no screen tearing, no wobbly effect in middle:

[sdl]
fullscreen=true
fulldouble=true
fullresolution=desktop
windowresolution=original
output=ddraw
autolock=true
sensitivity=100
waitonerror=true
priority=higher,normal
mapperfile=mapper-0.74.map
usescancodes=true

[dosbox]
language=
machine=svga_s3
captures=capture
memsize=16

[render]
frameskip=0
aspect=false
scaler=hq2x

[cpu]
core=auto
cputype=auto
cycles=6000
cycleup=10
cycledown=20

[mixer]
nosound=false
rate=44100
blocksize=1024
prebuffer=80

[midi]
mpu401=intelligent
mididevice=default
midiconfig=

[sblaster]
sbtype=sb16
sbbase=220
irq=7
dma=1
hdma=5
sbmixer=true
oplmode=auto
oplemu=default
oplrate=44100

[gus]
gus=false
gusrate=44100
gusbase=240
gusirq=5
gusdma=3
ultradir=C:\ULTRASND

[speaker]
pcspeaker=true
pcrate=44100
tandy=auto
tandyrate=44100
disney=true

[joystick]
joysticktype=auto
timed=true
autofire=false
swap34=false
buttonwrap=false

[serial]
serial1=dummy
serial2=dummy
serial3=disabled
serial4=disabled

[dos]
xms=true
ems=true
umb=true
keyboardlayout=auto
avatar
HenitoKisou: This is how my dosbox_epin.conf looks, no input lag, no screen tearing, no wobbly effect in middle:
YES YES YES YES!! THANK YOU!

This solved all of my issues. I could actually aim with the flippers and try to do things. My high score jumped up 7x immediately.

Thank you so much!