It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hi all, just bought EECH today & badly wants to play the game, after installation i tried to run the game but it states a fatal error upon starting:-
Unable to register directplay commanche Hokum DPERR_GENERIC
Then after reading some post on the forum i tried editing the registry
But instead of running i got another error:-
DirectP Unable to create Directplay4A
Tried my best for everything just couldn't work it out, any ideas?
I had a similar problem. The game crashed on startup giving a graphics error. I have a nvidia GTX280 card. Both EEAH and EECH crashed on the first few starts. EEAH finally was able to do it's graphics test on the thIrd start. EECH does not do this check but started after a few tries.
After these first few crashes the games finally seem to start OK. Had not been able to play test yet as I have never flown a hele sim and have not got my joystick working yet, or worked out the controls.
I can not give any advice as my problem looks to be fixed after just trying repeated times.
One thing you could try is downloading the "eech-allmods-1.130.exe" mod. It's updates my help. It is a 706MB file. See the top sticky for the link for this file. I am downloading now.
Item 2 on the below link is the above mod update, right click then save as.
If you work it out please post your solution.
Regards MarkL
Unfortunately, even after exaclty NINE years since this topic was started, the problem still survives, despite a clean install of the EECH March 5th 2016 v1.16.0FIX1. Old problems never die and the now decade-old error "Unable to register directplay COMANCHE HOKUM DPERR_GENERIC". Sadly, it will cause me to uninstall this awesome sim.