It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Trying to run this game on a Windows 10 64-bit installation with a GTX670 I was getting sub 10 FPS frame rates.
As I have found no solution to this problem around the internet I'm posting what worked for me in case some one else also has the same problem.

Simply running the main executable via DXWnd allows the game to run perfectly on my system.

https://sourceforge.net/projects/dxwnd/

Run DXWnd as administrator and drag aphavoc.exe from the games install directory into the window that opens up.

Right click on aphavoc.exe inside DXWnd and click modify and uncheck "Run in Window"

Double click on aphavoc.exe inside the DXWnd window to start the game.

The game should hopefully run fine. You will even be able to increase the resolution by pressing ctrl + F4 without the game crashing. Just don't expect the 2D hud to fit properly anymore.

Hopefully this helps someone. :)
Post edited May 27, 2018 by CaptainWabbit
I know it's been a while since this post, but for everyone else passing by: This did the trick for me as well. I haven't managed to run the game in fullscreen mode yet, but at least it works.