It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Martin_Pedersen44: EVERYBODY! just switch compatibility to WINDOWS 8 it worked for me :-)
and can i change the compatibility ?
TheOneAnOnlyUser: Since I have not found this solution anywhere else: For me the freezing only occurred when I used GOG Galaxy to download EE. As soon as I installed it using the Offline Installer instead, it worked flawlessly. I am not sure whether this has to do with how GOG Galaxy handles administrator rights, differing versions on the Offline and Galaxy installation or something else. Either way, after that, it worked without any additional patches whatsoever, which is why I would recommend attempting this before doing anything else.
how can i do it ?
Post edited November 26, 2018 by Margok321
I can get the game to run fine without changing any settings, the problem is when I play on a created map it'll play for a few hours then unexpectedly close... I built a world history based story, but almost every map besides one or two unexpectedly close the game, with no error msg, nothing, straight to home desktop... Nothing more disappointing then getting to the interesting battles and it just closes.... I thought maybe its the water on space maps but dosen't explain why the map plays for awhile then poof..... Ive been a die hard fan of EE and its map builder, this is the first time I have ever had a problem... Going to move maps to a lower computer to see if its just windows 10
I had trouble getting Empire Earth running on Windows 10 64 bit. The game installed and launched no problem, but starting any game and it went to black screen with sound in background! After coming back to it a year later, I figured it out.

After launch I went to the settings and changed the screen res from 1920 * 1080 32 bit

to 1920*1080 16 bit

Game runs without problem in this mode.

John, hope this helps
I wanted to add this.
I recently had great results from this link.
you'll have to add the www part.
I found out that there are certain files that are not included in Windows 10 64 bit that are required by some older games to work. This link from Microsoft adds those files back in without writing over newer files. So, those older games can now access them.
The link to the Microsoft website has a download link for the DirectX End-User Runtime Web Installer which may be missing on your machine as well.
Thanks to the Tech Support Representatives here at GoG: Falran and Ponczo for finding this link for me. It was what I needed to get Empire Earth to work.
I hope that this helps others too. Good luck.
Latest automatic patch is the biggest joke ever seen and an error from and it fix nothing
you must downgrade version if you want play with the latest version without any bug :
Steps to do :
1) Downgrade in galaxy library, select empire earth in game list, click on "more" blue button and select "settings", uncheck automatic update to the newer version, select 27117483 version.
2) Click again on "more" blue button, manage installation, and verify / repair, and let it job done,
3) On your desktop, two shortcut has been created, right click on the game shortcut you will want to play, select properties, go to Compatibility tab select : "windows 8" in OS list compatibility, check "disable full screen optimizations", and "run this program as administrator"
4) launch the game and look at top left of the main menu, you will see : 2.00.3466 this number match with the real latest version of this game, not the older f*****g patch.
5)Quit empire earth, and in compatibility tab shortcut's properties, uncheck run compatibility mode for win 8
6) Its done ! you have the latest version without graphics glitch. Launch empire earth, and enjoy !
Post edited October 29, 2019 by FrobozzMC