It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
high rated
Hey guys if you wanna play multiplayer download a patch from www.neoee.net they have brought back the server what sierra used for online gaming hope you enjoy any problems message back il try to help i uploading a screen of the multiplayer server we brought back to life

Game:
Increased compatibility to Windows 8 and newer graphic cards
Added "New Plains" map type
SFX:
enhanced the nuclear light flash
Updater:
Fixed a critical bug that causes timeout during patching
Fixed a graphical bug that hides progress percentage
Interface:
Adjusted the splash screen and main menu background to emphasize the NeoEE patch
Removed many references to sierra.com and replaced it with NeoEE.net
Replaced Sierra icons and banners in lobby by NeoEE icon/Empire Earth heaven banner
Replaced the "Community" tab by the "NeoEE.net" tab; however its contents are still under construction
Multiplayer:
Implemented the first version of a new technology that allows hosting games with RIP pings/no forwarded firewall ports.
More information...
Changed the timeout waiting time after a host left the game ungracefully from 65 seconds in 10 second steps to 20 seconds in 5 second steps
Attachments:
ee_server.png (456 Kb)
Post edited May 05, 2014 by Save-EE
Hello.
First of all: Good job with NeoEE patch! It's really amazing. I personally don't like EE1, but I'm really happy that a group of people keeps the game alive.

If you have problems with Empire Earth 1 on Windows 8 / 8.1, please check out this guide:
http://easywinclan.forummotion.com/t1707-ee1-empire-earth-and-empire-earth-the-art-of-conquest-windows-8-81-fix
Hopefully it help you to solve all the problems with the game.
I have no clue why, but with this patch applied the game crashes when a game is started. Not even uninstalling the patch fixes it, I need to uninstall everything and reinstall EE from scratch.
avatar
DrMonaLisa: If you have problems with Empire Earth 1 on Windows 8 / 8.1, please check out this guide:
http://easywinclan.forummotion.com/t1707-ee1-empire-earth-and-empire-earth-the-art-of-conquest-windows-8-81-fix
Hopefully it help you to solve all the problems with the game.
FWIW I had the horrible screen glitch issue and none of the fixes in the above link worked for me. And a few days ago, I did fix it at last, and it was by accident while trying to fix some other thing with my drivers. Sorry for the long post but I've been through a lot with this issue and I feel the more information the better.

I have an Asus N750JK laptop with Windows 8.1, a NVidia GTX850 and an Intel HD 4600. Both graphic drivers were apparently updated to the last version, or at least that is what both the Windows device manager and the Asus product page said.

If you go to my specific laptop model page in Asus (N750JK), they say my latest Intel HD drivers are V10.18.10.3368.01 (Updated 2014/07/04), BUT if you go to this other page:

http://support.asus.com/Download.aspx?SLanguage=en&m=VGA&os=30

there is another version of the Intel HD driver, Version V10.18.14.4062.01 (Updated 2015.02.03). Now, all I did was uninstall the old driver and install the new one. Then run the game using the Intel GPU (not the NVidia one) and there you go: the game runs flawlessly without any video tearing or weird screen stuff at all.

Notice that I had to use these specific drivers because Asus laptops apparently need custom Intel drivers provided by the vendor, and indeed I wasn't able to install the Microsoft generic driver, it didn't let me and redirected me to the Asus website instead. But I guess the version numbers are right whatever the specific "flavor" of the driver installer.

That is all, I hope this helps some of you.
Post edited February 25, 2015 by svmariscal
avatar
DrMonaLisa: If you have problems with Empire Earth 1 on Windows 8 / 8.1, please check out this guide:
http://easywinclan.forummotion.com/t1707-ee1-empire-earth-and-empire-earth-the-art-of-conquest-windows-8-81-fix
Hopefully it help you to solve all the problems with the game.
avatar
svmariscal: FWIW I had the horrible screen glitch issue and none of the fixes in the above link worked for me. And a few days ago, I did fix it at last, and it was by accident while trying to fix some other thing with my drivers. Sorry for the long post but I've been through a lot with this issue and I feel the more information the better.

I have an Asus N750JK laptop with Windows 8.1, a NVidia GTX850 and an Intel HD 4600. Both graphic drivers were apparently updated to the last version, or at least that is what both the Windows device manager and the Asus product page said.

If you go to my specific laptop model page in Asus (N750JK), they say my latest Intel HD drivers are V10.18.10.3368.01 (Updated 2014/07/04), BUT if you go to this other page:

http://support.asus.com/Download.aspx?SLanguage=en&m=VGA&os=30

there is another version of the Intel HD driver, Version V10.18.14.4062.01 (Updated 2015.02.03). Now, all I did was uninstall the old driver and install the new one. Then run the game using the Intel GPU (not the NVidia one) and there you go: the game runs flawlessly without any video tearing or weird screen stuff at all.

Notice that I had to use these specific drivers because Asus laptops apparently need custom Intel drivers provided by the vendor, and indeed I wasn't able to install the Microsoft generic driver, it didn't let me and redirected me to the Asus website instead. But I guess the version numbers are right whatever the specific "flavor" of the driver installer.

That is all, I hope this helps some of you.
can you tell me how you did that step by step
nothing listed here really works, game still freezes
my game still freezes, i dont know why....
please help
I had a problem with both Empire Earth and Empire Earth Art of Conquest in Windows 7 Pro. Both games had no text and Art of Conquest artifacted (bad graphic glitches). I have a Geforce 780ti. 1. Down load a program Called DDU version 17.0.6.6. it uninstalls all the drivers for your GPU. 2. Download the latest drivers from your GPU site (I think this might work for AMD also and put them on your desktop. 3. Download the patch from NEO-EE to play on line. 4. Uninstall and reinstall the games (or just EE) ( with any update patches from Sierra). 5. Install the NEO-EE patch. 6. Uninstall your GPU drivers with DDU. 6.Reinstall your GPU drivers from your desk top. Empire Earth and Empire Earth Art of Conquest will work perfectly. If you reinstall the games and uninstall and reinstall the drivers for you GPU and then the NEO-EE patch it will revert the games back to the problem you had in the first place, you must install the NEO-EE patch after reinstalling the game or games before uninstalling and reinstalling your GPU drivers. You can try this method on 8, and 10 it might work. This method did not work for winxp home as far as Empire Earth Art of Conquest was concerned. Empire Earth worked fine in WinXP without this method.
Where exactly do you install this patch? The installer says the game is not detected. I installed the patch manually, but I'm not sure if I did it right. The game still didn't work though. I need assistance.
Post edited August 15, 2017 by Riekopo
avatar
Riekopo: Where exactly do you install this patch? The installer says the game is not detected. I installed the patch manually, but I'm not sure if I did it right. The game still didn't work though. I need assistance.
It is probably too late for you but I found the solution, you need to place the NEO-EE.msi file into your empire earth repository. If you have the gold edition from gog, you need to place it inside empire earth gold edition (in your gog library). It is the folder where you can see two subfolders: EE and EE AoC.
Neo-ee.msi is flagged as having a trojan horse by Windows Defender.
Pretty sketchy, flagged as well for trojans.
I did a bit of digging and here's what I found:

The NeoEE.msi contains a binary called PAYLOAD (.exe):

PAYLOAD (.exe)
SHA256: 19943fe1b6d22d2b585d130da4808ee82485f41b96a76a69ccd3fb2c5847012d
VirusTotal: Detection ratio: 39/68

Digging more into that PAYLOAD exe, it contains more files, one of them being "New Project.res" which is really a 7zip file. There are many files inside this "New Project.res" 7zip file, but the interesting one is authtools.exe.

Authtools.exe seems to be considered bad because it tries to connect to VBOXSVR[dot]ovh[dot]net which is considered a malicious site according to some. See here (bah, I'm not allowed to post links): threatcrowd[dot]org[slash]domain.php?domain=vboxsvr[dot]ovh[dot]net as this site says "Most users have voted this as MALICIOUS"

VirusTotal shows a bunch of .exe with porn filenames (example: WhateverPorn.mpg.exe) that also connect to VBOXSVR.ovh.net.

So as much as I'd like to play Empire Earth online with friends, I can't trust this. If the author can explain why this tool is needed, or better yet, remove it, then I think the anti-virus community might not see this installer as bad.
Well you shouldn't have to use tools to play it if you bought it at this day and age.
It should have proper support by default.
Else it shouldn't be sold.