It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
avatar
abr_alex: Hi everyone.
I've had troubles running Empire Earth: Art of Conquest installed with Galaxy on 3 different PCs (game simply crashed on startup). Then I tried installing it with offine installer (GOG Downloader version) and suddenly it worked fine on every PC i tried it.
So GOG needs to check their Galaxy version and fix it up.
avatar
EntropicCow: This is the only solution that has worked for me so far.
This fixed the majority of my problems as well.

I can get in game now, but I'm still trying to figure out why the screen stops refreshing when I select certain buildings to construct, then freezes completely 20 seconds later.
My Setup is Windows 10 with a Core-i7-7700 and a Geforce 1060 with 6GB and i had the same Problem with a Freezing game in the Menu.

What worked for me, was installing without GOG-Galaxy, using the compatibilty mode for Windows 7 as an admin and changing the grafix to my Geforce instead of primary driver and Direct3D Hardware TnL with a resolution of
800x600x32.

I disabled all renderers and grafic effects, but maybe it would work with them enabled. I dont have the courage to try, after i finally got the game working.

You are also able to change the settings with regedit under "\HKEY_CURRENT_USER\Software\SSSI\Empire Earth"...

Hope you get your game working...
Can confirm installing the non-Galaxy version stopped my game freezing at the start menu also.
So here is a 3 year update. The game still does not work. i have friends and family who have the same game and it works on their window 10 pcs. I have found that the problem my computer is having is a low-level engine dll error. I believe it is graphic card based but not sure. I have done everything from installing with antivirus off to updating drivers etc. I cannot seem to find a fix for this issue. Also i can't change my graphics card's hardware acceleration. I don't if this new information sheds like on anything but there is where i am at.
Post edited June 22, 2019 by ddrhousehq
In case the other suggestions do not help:
Disabling the MSI Afterburner (Riva Tuner Statistics Server) Overlay ( for Hardware usage and such) solved the issue for me.
No other tweaks or compatibility settings needed.
So it might be worth disabling this or any other overlay that might be running in the background.
Post edited August 14, 2019 by SharxX8