It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Just to help anyone who was having this issue:

I purchased Emperor on GOG as I've owned the original for years and played the heck out of it. I never installed the widescreen mod on the original, but I decided to give it a shot this time and ran into a conundrum:

Playing the game unmodded gave me no lag whatsoever; however, playing the widescreen version gave me severe lag every time I moved my mouse. As I play on 100% speed and abuse the pause function this was horrendously annoying, and I finally narrowed it down to the Polling rate on my Corsair Scimitar gaming mouse. Having the polling speed set to 1000hz and 1ms was causing the lag- turning it down to 125hz and 8ms removes the lag (almost) entirely and allows me to play.

I made the usual adjustments of turning off scaling and high DPI settings with no luck, so I'm fairly sure the game simply isn't optimized for higher refresh rates on mouse polling.

Hope this helps someone!

Edit: I've tested 500hz now and the problem is definitely noticeable still. :(
Post edited April 27, 2019 by ShinyKakapo