It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
How do I get my people to show up for the acrobat building, tax office, the mill and other building that did display up to yesterday, but then stopped showing them. tried to put it in again but that didn't work. Would appreciate any help. Thanks, Peggy


The game is " Emperor Rise of the Middle East"
Post edited August 09, 2018 by pegloross
How long has your computer been on? Try restarting your computer. These kind of animation bugs can occur if you only sleep your computer and not shut it down.
I have the same problem. I've restarted multiple times over the last few days, updated my driver, reinstalled the game, ran it as administrator, and tried Windows XP compatibility mode. Still got nothing. I hadn't played the game in a while, and I'm sure this didn't happen before.
are you using cheat engine?

is it a legal copy of the game?

do you for some reason keep tabbing out?

all of these can cause it and the only solution i have is completely uninstall/delete the game from all locations and reinstalling it can give you a 50% at fixing it.
Post edited September 22, 2018 by Aranwen1