It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
high rated
Hello fellow Linux gamers!

Here youʼll find scripts building packages for Debian, Arch Linux, Gentoo and any derivative (Ubuntu, Manjaro, Linux Mint, etc.) from your installers for The Elder Scrolls games.
These packages can be installed easily with you favourite packages manager.

Download links and usage instructions can be found on the following pages:
The Elder Scrolls: Arena
The Elder Scrolls Ⅱ: Daggerfall
The Elder Scrolls Ⅲ: Morrowind

We hope youʼll enjoy the ease-of-use provided by these scripts as much as we enjoy writing and tweaking them ;)

Here you go for more supported games!

-----

Salut camarades Linuxiens !

Vous trouverez ici des scripts construisant des paquets pour Debian, Arch Linux, Gentoo ou nʼimporte quelle distribution dérivée de celles-ci (Ubuntu, Manjaro, Linux Mint, etc.) à partir de vos installateurs pour les jeux The Elder Scrolls.
Ces paquets sʼinstallent facilement via votre gestionnaire de paquets habituel.

Les liens de téléchargement et les instructions dʼutilisation se trouvent sur les pages suivantes :
The Elder Scrolls: Arena
The Elder Scrolls Ⅱ: Daggerfall
The Elder Scrolls Ⅲ: Morrowind

Nous espérons que vous apprécierez le confort apporté par ces scripts autant que nous apprécions les écrire et les améliorer ;)

Pour plus de jeux, rendez-vous par ici !
Post edited February 21, 2020 by vv221
update

Support added for The Elder Scrolls III: Morrowind
Update
Arena and Daggerfall only

Script updated to ./play.it 2.0
Arch Linux support added
Update

Arch Linux support added to the script for Morrowind
The menu entry for Morrowind now runs the launcher instead of directly starting the game
⚠ Following instructions are no longer useful, current ./play.it script has support for innoextract 1.8

-----

The latest GOG installer for Daggerfall is not officially supported by ./play.it yet, but it already works on our development version.
The process is a bit trickier than with our usual scripts, as we don't have support for InnoSetup 5.6.2 (the packaging format currently used for Daggerfall GOG latest installer).

Here is a small guide to get it working.

1. Install innoextract 1.8 development version

Install innoextract build dependencies, then:
git clone https://github.com/dscharrer/innoextract.git ~/innoextract.git
mkdir ~/innoextract.git/build
cd ~/innoextract.git/build
cmake ..
make
mkdir ~/bin
cp innoextract ~/bin/
cd
rm --force --recursive ~/innoextract.git
 
2. Install the patched ./play.it library allowing to use the development version of innoextract + the development version of the ./play.it script for Daggerfall
 
git clone https://framagit.org/vv221/play.it.git ~/play.it.git
cd ~/play.it.git
git checkout dev-2.x/games/update/the-elder-scrolls-2-daggerfall/new-archive
./play.it-2/patches/skip-innoextract-version-check.sh
make
make install
cd
rm --force --recursive ~/play.it.git
 
3. Run the ./play.it script

Open a terminal in the directory including the Daggerfall installer, then:
PATH="$HOME/bin:$PATH"
play.it "./setup_the_elder_scrolls_ii_daggerfall_1.07_(28043).exe"
 
4. Follow the instructions given by the script to install the game

5. Enjoy ;)
Post edited October 23, 2019 by vv221
Update

Morrowind

You now have a choice of running the game through WINE
or OpenMW native engine.
Post edited April 23, 2019 by vv221
Update

The Elder Scrolls II: Daggerfall

* Build a single arch-agnostic package
* Add missing files to user-writable ones
Update

The Elder Scrolls II: Daggerfall

* New installer supported:
  - setup_the_elder_scrolls_ii_daggerfall_1.07_(28043).exe
Update

The Elder Scrolls: Arena

* Tweak DOSBox settings to improve performances