It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
avatar
mutishev: Hello and thanks for the great guides and wine wrapper.

I am trying to play Oblivion on Linux Mint, on a laptop (i5 4210m, 16gb ram, HD4600, SSD).
Unfortunately the game is lagging crazy in the main menu, not sure how could I fix it.

Any advice would be welcome :)

EDIT: renamed the Video folder and now I can sort of move the mouse in the main menu and even start a new game. Although the game is still stuttering every couple of seconds.
avatar
abbayarra: What are you using for sound? I have the Asus Xonar sound card and Oblivion would stutter like crazy. If you have EAX or other surround sound programs Oblivion will stutter due to sound. You have to go to the audio center and turn off the GX/EAX mode.
I am using the default sound of the laptop, there is nothing special to turn off in the settings... :(
avatar
mutishev: Hello and thanks for the great guides and wine wrapper.

I am trying to play Oblivion on Linux Mint, on a laptop (i5 4210m, 16gb ram, HD4600, SSD).
Unfortunately the game is lagging crazy in the main menu, not sure how could I fix it.

Any advice would be welcome :)

EDIT: renamed the Video folder and now I can sort of move the mouse in the main menu and even start a new game. Although the game is still stuttering every couple of seconds.
It's not a problem I've encountered before, but it's probably a combination of issues with the Intel graphics drivers and the weak integrated GPU. You could try running the game in a virtual desktop, or if that doesn't work then you could also try setting LIBGL_DRI3_DISABLE=1 when running the game as I've found that to help in some cases:

LIBGL_DRI3_DISABLE=1 ./start.sh play

Also if you haven't already I recommend uninstalling the xserver-xorg-video-intel package as that's a legacy driver for older chipsets & can cause problems with newer Intel GPUs.
avatar
mutishev: Hello and thanks for the great guides and wine wrapper.

I am trying to play Oblivion on Linux Mint, on a laptop (i5 4210m, 16gb ram, HD4600, SSD).
Unfortunately the game is lagging crazy in the main menu, not sure how could I fix it.

Any advice would be welcome :)

EDIT: renamed the Video folder and now I can sort of move the mouse in the main menu and even start a new game. Although the game is still stuttering every couple of seconds.
avatar
adamhm: It's not a problem I've encountered before, but it's probably a combination of issues with the Intel graphics drivers and the weak integrated GPU. You could try running the game in a virtual desktop, or if that doesn't work then you could also try setting LIBGL_DRI3_DISABLE=1 when running the game as I've found that to help in some cases:

LIBGL_DRI3_DISABLE=1 ./start.sh play

Also if you haven't already I recommend uninstalling the xserver-xorg-video-intel package as that's a legacy driver for older chipsets & can cause problems with newer Intel GPUs.
Before I saw your post a friend of mine asked me if I have enabled hardware acceleration in xorg.conf, I said to him that I think it is enabled by default, but it was not. When I enabled it and restarted the lag was no more :)

I had to tweak it some more, because I had the black skin bug, but now the game is ok.
The only problem I still have is that the mouse get locked in the game screen and I can not move it to other windowses althou I play it in windowed mode....
Any advice would be welcome :)
avatar
mutishev: The only problem I still have is that the mouse get locked in the game screen and I can not move it to other windowses althou I play it in windowed mode....
Try using alt+tab to switch to another window & free the mouse cursor
avatar
mutishev: The only problem I still have is that the mouse get locked in the game screen and I can not move it to other windowses althou I play it in windowed mode....
avatar
adamhm: Try using alt+tab to switch to another window & free the mouse cursor
Thank you!
Another thing, alt + space opens Cinnamon window menu and from there one can minimise the window.
avatar
adamhm:
I installed Oblivion today, however I have two problems.
First I used the wrapper you made with wine 2.9 staging. It had perfect performance. But my character's skin was black regardless of the settings. This is a known bug that can be fixed. The second issue I had is that my character can't move.
Then I tried your current wrapper which fixed the skin rendering issue. Unfortunately, the movement doesn't work either and additionally my performance is absolutely horrible.

If you know a solution for the movement on top of your head, I would appreciate that.

Apart from that, I would argue that you should return to the 2.9-staging wrapper or offer both options in the installation. The performance is just so much better in the old wrapper.

Another thought is: It would be useful if you'd only check the exact installer name and checksums if the user wishes so. There's no way that the Oblivion installers have gotten relevant updates.

Thank you for your work! :)
Solved it. Oblivion thought my mouse was a controller.
Now the 2.9 version works great. Please offer this version again.
Post edited June 09, 2019 by 0Grapher
hmm, 2.9-staging is *ancient* & there shouldn't be any reason for it to have worse performance; on my systems Oblivion runs just as well with 4.0-staging as before, otherwise I wouldn't have updated it.

What distro and GPU/graphics drivers are you using?
avatar
adamhm: hmm, 2.9-staging is *ancient* & there shouldn't be any reason for it to have worse performance; on my systems Oblivion runs just as well with 4.0-staging as before, otherwise I wouldn't have updated it.

What distro and GPU/graphics drivers are you using?
It may not be because of the wine version. It's probably because of the configuration,
Linux Mint 19.2. Idk which drivers, lshw says i915, it's an integrated Intel card.

I can't remember how I got the console working the last time. Do you know an easy way? I would change my keyboard layout but I don't know in what way I need to change it. Otherwise I'll get an OBSE plug-in tomorrow.
Post edited June 09, 2019 by 0Grapher
avatar
0Grapher: It may not be because of the wine version. It's probably because of the configuration,
Linux Mint 19.2. Idk which drivers, lshw says i915, it's an integrated Intel card.
There is no Mint 19.2 release yet... I guess you mean 19.1?

If it's an Intel GPU then you're using the open drivers. If you haven't already done so I'd strongly recommend adding the Padoka Stable Mesa PPA to update to a newer Mesa than is provided by default (after adding the PPA and updating the package cache, install it via the Update Manager and then reboot). Also remove the xserver-xorg-video-intel package as that's a legacy driver to provide support for older Intel GPUs and has been known to cause issues with newer Intel GPUs.

If those don't fix the performance issue, here are some other possible solutions:

- Under System Settings --> General, set "Disable compositing for full-screen windows" to "on".
- Try running the game with LIBGL_DRI3_DISABLE=1, e.g.: LIBGL_DRI3_DISABLE=1 ./start.sh play
- Go to Advanced options --> Advanced Wine options and set MaxVersionGL to 30001

avatar
0Grapher: I can't remember how I got the console working the last time. Do you know an easy way? I would change my keyboard layout but I don't know in what way I need to change it. Otherwise I'll get an OBSE plug-in tomorrow.
Could just try different keys until it works :p The ` key accesses the ingame console here.
avatar
adamhm: There is no Mint 19.2 release yet... I guess you mean 19.1?
Yeah, confused it with the one I had before.

I'll keep your performance tips in mind. But everything runs perfectly except for the 4.0 version of the wrapper. It's really the wine version that causes the problem. All other games and the earlier wrapper work well. I don't think I should use the newer one.
Do you think I will definitely not break anything if I remove xserver-xorg-video-intel?

avatar
0Grapher: Could just try different keys until it works :p The ` key accesses the ingame console here.
That doesn't work. It's the key to the left of 1 and below Esc. In Britain that is `, here it's ^ as a dead key. That doesn't work in wine. But using another layout did work after all. When I tried it yesterday it just didn't properly change to the new one and that''s why it had no effect.