It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstar
I just wanted to add that 1440x900 fixed the F1 "construction center" crash. I usually set for 1360x768 but that would crash. With 1440x900 I have small black bars on the edge of my screen. 1024x768 worked too. So as long as I don't use a resolution that fills the screen, it works!
Greetings all. To fix the game crash problem, first delete the gog supplied shortcut on your desktop, then go into the Escape from Blue Planet folder and left click Earth2150 application so that it is highlighted. Right click on that, then select send to desktop (create shortcut). Problem solved. I'm running Windows 7 Home Premium with a max res. of 1366x768 on my laptop. Game now playes fine. Hope that helps :-). P.s. try clicking on your graphics driver (not your display driver), graphics options, panel fit, scale full screen. This setup should work. I also play on my wide screen t.v. with a max resolution (on t.v.) of 1920x1080.
Post edited April 16, 2012 by Randall415
Good thinking. However, will this work for Lost Souls and Moon Project? I'm going to find out.

avatar
Randall415: Greetings all. To fix the game crash problem, first delete the gog supplied shortcut on your desktop, then go into the Escape from Blue Planet folder and left click Earth2150 application so that it is highlighted. Right click on that, then select send to desktop (create shortcut). Problem solved. I'm running Windows 7 Home Premium with a max res. of 1366x768 on my laptop. Game now playes fine. Hope that helps :-)
It would be nice if I could run this Earth 2150 in a stable mode at 1920x1080x32 full screen but sadly that is not the case :(. I can run it at 1280x1024x32 windowed and it works real well. Too bad Randall415's suggestion does not work. It did look like it was till it crashed about 10 mins into game play. So windowed mode is the only way to go it seems.
Attachments:
Post edited March 21, 2012 by Trebor
However in the setup for The Moon Project and Lost Souls there is no option to run the game in windowed mode so Randall415's fix is the only way I can run those games. Funny how the option to run in windowed mode is only with Earth 2150 Escape from the Blue Planet.
Post edited March 21, 2012 by Trebor
Guys, guys guys guys...

you realize that if you do any sort of wide screen ratio it will crash due to the fact the game is incompatible with them right?
better late than never. try turning off autorun and play intro in the setup app.
avatar
Magron: better late than never. try turning off autorun and play intro in the setup app.
Hmmm...
idk...
I have the original pack with both CDs and I can´t install due to incompabilties between 16 and 64 bits (Win 8.1)
Help anyone?