It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hello! In the italian GOG version of Dying Light the intro video ("Harran") is in english with italian subs, while in the Steam version it's in italian. I don't know if it's supposed to be that way because of slight differences between the two versions, just wanted to bring it up :D

Also, in the Steam version you can play with english voice acting but italian text/subtitles, while it's not an available option in the GOG version. Can we get that option here too?

Maybe I'm just blowing in the wind, since I don't know if the developers read these forums.
Post edited May 02, 2018 by Desmight
No posts in this topic were marked as the solution yet. If you can help, add your reply
It's the same bug wiht german language. Everything is in german, just like the steam and the ps4 version. But the intro is in english. It is a minor bug, so i can live with it.
Nothing "little" about it imo. The game is available with the intro being localised in multiple languages on Steam - the German one can be heard here

https://www.youtube.com/watch?v=dGb-8j-OBE8

Will contact support.

I checked every version of the game here on GOG using the Galaxy rollback feature and it has been wrong SINCE RELEASE. Time to fix it.
Support ticket sent.
Also I examined the game a bit more and figured out that the intro file actually already IS multi language. The intro movie is stored in

\Dying Light\DW\Data\Menu\Movies\RealFootage\Intro.bik (normal quality)
\Dying Light\DW\Data\Menu\Movies\RealFootage\Intro_LQ.bik (low quality)

The bik file itself contains 8(!) audio tracks. Using BIKplay (which is part of the RAD Video tools) you can listen to every trck by calling the filrs with the parameters. In example

bikplay intro.bik /t1

Would play the intro with track 1 (keep in mind that the first track is numbered 0 which is English)

Please don't ask me which track is which language but I can say for sure that track 0 is English and track 5 is German. The problem is that the paramameter to play the correct audio track depending on the language settings apparently is not called from the game (I had the same problem in the Steam version of Syberia). So it's a fixable bug.

As I said, I experienced this in Syberia 2 (Steam version) as well and the same workaround should work here as well. I created a script simply copying the wanted audio track (in my case track #5) over the always played track 0. I will see if I can adapt my Syberia 2 solution and post here as well. I also hope that GOG will fix this issue on their side so that we don't even need such a workaround at all.

Will post thie workaround here for those interested.
Post edited December 06, 2018 by MarkoH01
@MarkoH01 Thanks for the tests and all the info. Let's see what the support team has to say about this, then. Again, it's not a major issue for me personally, but it's an issue and if possible it should be fixed. Once more, thank you :D
Workaround to fix the Dying Light English language only in Intro movie

=> Before doing anything backup your two intro files intro.bik and intro_lq.bik which are stored in
\Dying Light\DW\Data\Menu\Movies\RealFootage just to be safe in case anything should go wrong.

1) Download the fix from here
https://drive.google.com/open?id=1T-rVsQj0PiomALYSQDv36Ky3z3TfUjuV

2) Extract the archive anywhere and install the included RAD Video Tools

3) Open the script (Dying Light Fix.rlst) that is also included in the archive using an editor like notepad and change the pathname in the first line according to the path where your Dying Light Intro files (Intro.bik / Intro_lq.bik) are stored. After that you need to change the audio track you want to extract by by changing the parameter /n5 in the first lines of the script.

Since I don't know which track corresponds to which language you might have to experiment:

n0 = English
n1 =
n2 =
n3 =
n4 =
n5 = German
n6 =
n7 =

(If anybody should test this and could complete the missing languages I would appreciate you posting it here so I can fill in the blanks :))

4) Save the script (using the same extension!) and run it through double click. A window will appear and you click start. After that process has ended close the window by clicking "close" and answer the question ("Save this RAD batch list?") with "no".

5) After the processed is finished to wave files (intro.wav and intro_lq.wav) will have been added to the directory in which your intro files have been stored. If you like you can delete those since they are not longer necessary.

I tried it and it worked fine with German.
Post edited December 06, 2018 by MarkoH01
Got reply from GOG support as well:

"Hello,

Thanks for the feedback. Indeed it looks like a mistake on our part. I've already informed our Product Team about this issue.

We will try to resolve it as soon as possible. I'm sorry for current inconvenience."

So we probably just will have to wait until this will be fixed for good :)
avatar
MarkoH01: Got reply from GOG support as well:

"Hello,

Thanks for the feedback. Indeed it looks like a mistake on our part. I've already informed our Product Team about this issue.

We will try to resolve it as soon as possible. I'm sorry for current inconvenience."

So we probably just will have to wait until this will be fixed for good :)
Thanks!
avatar
MarkoH01: Got reply from GOG support as well:

"Hello,

Thanks for the feedback. Indeed it looks like a mistake on our part. I've already informed our Product Team about this issue.

We will try to resolve it as soon as possible. I'm sorry for current inconvenience."

So we probably just will have to wait until this will be fixed for good :)
Great news, thanks!