It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I just wanted to start a (new) game. I see no reason why I should let dungeons2.exe or mono.exe into the network.
Alas, if my firewall is fully up the game crashes.
So I tried if the game has need to access the network for some registering ... and, a miracle, the game started up no problem after allowing dungeons2. exe and mono.exe to spew their nasty tracking stuff into the network.
For me this has a weird feeling ... like if I am being watched!

Why has the game to connect to the internet just to play single player mode?
Haven't installed it yet. But it sound like they've failed on completely removing the drm or the Calypso launcher to be exact.

By the way. Which version is it, is it gog-1 or gog-2? Maybe gog-2 fixes it.
Post edited September 10, 2015 by ELFswe
I would not know which version is installed, but I can not download the patch GOG1->GOG2

As the line to download the game is:
Dungeons 2 (Part 1 of 2) gog-2 46 MB
I would guess that the bin file and executable are already GOG2.

The patch only produces
404 - Not Found

:-)

PS: it seems I have 1.4.1.67
whatever that is translated into GOG counting.

PPS: is there a translation table from GOG version into the rest of the world version? For any game? I always have this issue!
Post edited September 10, 2015 by Godspeed
Don't know when you downloaded it. But I guess the patch came out within the timespan of 12 hours.

I'm also getting the 404 error. You could allways download the whole installer if you're connection allows it.
I've corrected the link to the patch now, so it should be downloadable - sorry for any hassle.

Will look into the original post further tomorrow morning.

EDIT: tested this last night on my own setup and discussed it with our QA team this morning - You may get some firewall interaction when trying to start a multiplayer game (due to portions of it being online), you should not be getting any for starting a singleplayer game. On my tests last night, I encountered no issues and was able to install and run the game perfectly without any internet connection or firewall pop-ups. We also test for this in our QA, as obviously this isn't something that should happen. Did you perhaps select multiplayer first and then proceed to the singleplayer?
Post edited September 11, 2015 by B0SC0
While the game doesn't crash for me, hitting "campaign" or "skirmish" does nothing. I get an obvious button click sound, but nothing happens. Very disappointing :-(
avatar
Darvin: While the game doesn't crash for me, hitting "campaign" or "skirmish" does nothing. I get an obvious button click sound, but nothing happens. Very disappointing :-(
Are you running gog-2? Can you provide any other additional info that might help to resolve this? :)
avatar
B0SC0: Are you running gog-2? Can you provide any other additional info that might help to resolve this? :)
I installed via Galaxy in the last few hours. I presume this would be fully up-to-date.
I should change the title, it is not only a "new campaign" that fails with blocking firewall, but the whole game crashes.

The reason why I first thought I cannot start a new campaign: I accidentally allowed (at first) dungeons2.exe into the internet, so I got the video of calypso and other stuff, but at the "mono.exe" query I denied access to the internet, leading to the assumption that I just could not start a new campaign if my firewall is up.

It seems both executeables need access to the internet. Sucks.
Might have something to do with the achievements. Nevertheless, the game should still run if no internet is available.

I installed 12 hours ago manually, so GOG-2 should be my current version. No patch applied, as the patch executeable says that I already have that version.
Post edited September 11, 2015 by Godspeed
OK - in relation to both of your issues, can I ask you both to reach out to our support team directly for assistance with these issues - They're better equipped than I to help out and in the brief tests I've conducted and spoken about with our QA team, we were unable to reproduce either issues, so I suspect there's something local going on here which will require further investigation.
Post edited September 11, 2015 by B0SC0
avatar
B0SC0: OK - in relation to both of your issues, can I ask you both to reach out to our support team directly for assistance with these issues - They're better equipped than I to help out and in the brief tests I've conducted and spoken about with our QA team, we were unable to reproduce either issues, so I suspect there's something local going on here which will require further investigation.
Thank you for trying. If there is no issue running dungeons 2 on your machine with disabled internet it has to be an issue on my end :-(