It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
This is what worked for me (tested with a Logitech g-9 and G-600 mouse).
Using Logitech gaming software version 8.51
http://www.logitech.com/en-us/support/10088?osid=14&bit=64

choose the download tab from the link. above.

I went into the Logitech Gaming Software and changed the mouse polling rate from the default 500 to 125. (I have not tested other rates but 125 works great).

I then created a profile with the gaming software so that when I run DK2 it chooses that setting.

I saw other posts about changing some setting with Logitech setpoint that may work for other people that have a mouse that utilizes that software (the G-9 use to).

I did not see the solution I utilized in a quick search on the forums so figured I'd offer it up here.

Happy gaming!

ps

At one point when trying to figure out the solution I had uninstalled all the Logitech software but the default polling rate must be 500 with no software installed.....so you need to have the software installed so that you can make the change.
Post edited February 06, 2014 by Byeohazard
This might also contain useful information for those with Mouse Acceleration problems

http://donewmouseaccel.blogspot.co.uk/2010/03/markc-windows-7-mouse-acceleration-fix.html
Post edited February 09, 2014 by devilhood
If you have mouse lag issues in windows 8.1 this is how i fixed it. This is copy paste from the microsoft support page about it.

Click Start, type regedit.exe in the Start Search box, and then press Enter.
Click Yes if the User Account Control dialog box is displayed.
Browse to the following folder:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

Note If the Layers key does not exist, right-click AppCompatFlags, click New, click Key, and then type Layers to create the key.
Create a new registry entry for the game. To do this, right-click Layers, click New, click String Value, type the full path of the game’s executable file in the box, and then press Enter.
Right-click the value, and then click Modify. In the Value data field, type NoDTToDITMouseBatch, and then press Enter.
Click OK to confirm the change. The registry key in Registry Editor should resemble the entry in the following screen shot.
Post edited February 14, 2014 by mgulbaek
Really informative thread. Thank you all for the info's and links :)
Any one experience their mouse pointer zooming to the edge of the screen , and then unable to use it ..
Only way out of the game is to control alt delete ..

The number of levels I have had to redo Is driving me scatty
avatar
jerryowen: Any one experience their mouse pointer zooming to the edge of the screen , and then unable to use it ..
Only way out of the game is to control alt delete ..

The number of levels I have had to redo Is driving me scatty
Jerry. Alt-r (save) then shut the game down, restart, and open saved.