It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera


I'm playing Dungeon Keeper 2 on Ubuntu thanks to Wine, and I met a bug that is quite embarrassing.

On some levels, it seems impossible to attract some creatures, such as gobelins (well I can go through) and, more important, black knights. I'm on the 15th level, with lord Volstag and the black knights that should be apppearing, I have a lair, a hatchery and a 5X5 pit but... no black knight (and no gobelin either :D).

As soon as I build another room such as a library or a torture chamber, I can get warlocks or mistresses.

Is there anything I can do ?

Many thanks in advance !
This question / problem has been solved by Loobineximage
Use this patch.
Hi Loobinex,

Thank you for your answer. I unpacked the files in the /usr/local/share/games/dungeon-keeper-2/data/editor/maps directory and restarted the level (by continuing the campaign) and... still doesn't work, unfortunately :(

Any suggestion ?
Not really, that should have worked.

Do you perhaps have the game installed twice,.... do you run '/usr/local/share/games/dungeon-keeper-2/DKII_dx.exe'?

Check that the folder you copied the files to contains all the other maps as well. (e.g. level1.kwd)
Make sure you've correctly overwritten the files in that folder, so that it contains a file called 'Level15aVariables.kld' which is last modified on 1999-08-05.
OK I found my error : the names didn't match exactly, in the patch they have a capital letter (for example level5Variables.kld) and on the game files thet do not (level5variables.kld).

So they didn't overwrite the game files ; now it is done and that works fine as far as I tried (level 14, I got those nasty dark knights).

Many thanks to you, Loobinex !