It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Rhodax: Same here, Enable directplay and it works on win10 x64. I didn't have to use any compatibility mode either.

Guess they used Directplay but didn't check for its existance first and throw a custom exception if it wasn't found.
My guess too. Also explains why DK II ran one one of my systems but not the other. Not sure why DirectPlay was enabled on one but not the other, but that was it.

-= Bill =-