}

It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
So i've got a folder for eDuke and i've made a seperate folder for in that one for one of the mods

i then start up EDuke and the name of the mod comes up in the 'Custom Game content directory' but not under the 'Game' part
The easiest thing to do is create a batch file (.bat) with the commands to run it.

But, basically, it's the following syntax :

eduke32 /x<Path to Mod>\<Con File> /g<Path to Mod>\<Group File>

Where <Path to Mod> is whatever subDIR you put the levels in. I suggest putting a Levels DIR in the main Duke3D DIR so you can keep things clean. IE - Duke3d\Levels\

No space between the x in the /x and the <Path to Mod>. Same thing with g and /g.

EG -

eduke32 /xmetropolitan.con /gmetropolitan.grp

or

eduke32 /gaddons\vacation.grp

or

eduke32 /xaddons\nwinter.con /gaddons\nwinter.grp
Post edited June 23, 2013 by Firebrand9
Batch file?

i've never made one before


get onto it now
Post edited June 23, 2013 by Blaze72
Update

I've done one not sure if i've done it right and also i don't have any .con in the mods that i have

eduke32 /C:\Games\Eduke\Platoon\Platoon.grp

???
avatar
Blaze72: Update

I've done one not sure if i've done it right and also i don't have any .con in the mods that i have

eduke32 /C:\Games\Eduke\Platoon\Platoon.grp

???
change that to:
eduke32 /gPlatoon\Platoon.grp
Post edited June 28, 2013 by Forge
Already got it working

also it goes Eduke32.exe /gplatoon.grp /xPlatoon.con

well that's what works for me.
avatar
Firebrand9: The easiest thing to do is create a batch file (.bat) with the commands to run it.

But, basically, it's the following syntax :

eduke32 /x<Path to Mod>\<Con File> /g<Path to Mod>\<Group File>

Where <Path to Mod> is whatever subDIR you put the levels in. I suggest putting a Levels DIR in the main Duke3D DIR so you can keep things clean. IE - Duke3d\Levels\

No space between the x in the /x and the <Path to Mod>. Same thing with g and /g.

EG -

eduke32 /xmetropolitan.con /gmetropolitan.grp

or

eduke32 /gaddons\vacation.grp

or

eduke32 /xaddons\nwinter.con /gaddons\nwinter.grp
How do you make batch files? Do you just use a text editor and save as .BAT?

EDIT: Never mind the above; you do indeed use a text editor. Also, Duke Caribbean on Megaton does not have a con file.
Post edited March 11, 2018 by darkredshift
avatar
Blaze72: Update

I've done one not sure if i've done it right and also i don't have any .con in the mods that i have

eduke32 /C:\Games\Eduke\Platoon\Platoon.grp

???
avatar
Forge: change that to:
eduke32 /gPlatoon\Platoon.grp
I tried that with Duke Caribbean and it did not work.
avatar
Forge: change that to:
eduke32 /gPlatoon\Platoon.grp
avatar
darkredshift: I tried that with Duke Caribbean and it did not work.
You shouldn't need to do that if you're using eduke32.
eduke32 automatically finds the vacation, dc, & winter grp files if you put them in the base duke3d directory.
On the eduke32 launcher screen there should be a drop-down list, or a box, with the duke3d.grp and vacation.grp files listed. Just select the one you wish to use.

If your launcher screen isn't appearing before the game starts, edit the eduke32.cfg file and change the line value of "Forcesetup" to "1"
avatar
darkredshift: I tried that with Duke Caribbean and it did not work.
avatar
Forge: You shouldn't need to do that if you're using eduke32.
eduke32 automatically finds the vacation, dc, & winter grp files if you put them in the base duke3d directory.
On the eduke32 launcher screen there should be a drop-down list, or a box, with the duke3d.grp and vacation.grp files listed. Just select the one you wish to use.

If your launcher screen isn't appearing before the game starts, edit the eduke32.cfg file and change the line value of "Forcesetup" to "1"
It's OK. I found I was using the wrong Eduke32 executable and I'd forgotten to place the RTS file in the main Eduke folder as well as the expansion one.

I need to point out that you need to disable autoload when running expansions if you have the high resolution pack and maybe have the tga files and music folders for your expansion in their directories for good measure, else the game will display base Duke Nukem 3D skyboxes and use the base game's music.

I don't know how to alter the title screen to display an expansion's respective one though.
avatar
darkredshift: It's OK. I found I was using the wrong Eduke32 executable and I'd forgotten to place the RTS file in the main Eduke folder as well as the expansion one.

I need to point out that you need to disable autoload when running expansions if you have the high resolution pack and maybe have the tga files and music folders for your expansion in their directories for good measure, else the game will display base Duke Nukem 3D skyboxes and use the base game's music.

I don't know how to alter the title screen to display an expansion's respective one though.
There are independant launchers for NW & vacation at this site:
http://hendricks266.duke4.net/
they include hrp packages for them as well.

This way you can drop the files straight from your cd into a clean directory, drop in the duke3d.grp file & the appropriate launcher.

Used to be one for DC too.

the hrp for DC is here:
http://hrp.duke4.net/download.php

don't know what happened to the launcher for it.
Post edited March 11, 2018 by Forge