It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Yesterday i purchase the Dragon Age;Origins UE from here. I install it, and everything go well, until first screen
The cursor moves, but refuse to activate buttons on my mouse !
I remember more than 10 years ago, when get the game at first time, I never had these isses. Plus everything else work fine in my PC. I never had experience problem such this.
I don't have problem with other GOG games either. But as I said, can't click anything on the start screen after i press 'play' from DAO client
I tried many soilutions search from internet, ( and there not many, few are on EA forums).Everyone had this problem, the only way to fix it, (especially people from Steam client) was to activate the original key through Origin's client and play it from there.
But Gog version have no such a key!
How soppuse to play it here?
If someone know and have some solution , please add it. As I said, I try everything, nothing works. And is the only game make my mouse don't work. Not at least even my keyboard so to move through keys in the start screen.
If there is no solution, then i still have time to refund it.
Post edited June 10, 2018 by darias
No posts in this topic were marked as the solution yet. If you can help, add your reply
I downloaded&played(without finishing it) DAO UE three month ago.
I had a problem with the mouse at the frist start but the reason where wrong setting at the launcher, i didn't need any keys or onlinelogin. Just try to start the launcher, choose configuration and check the settings, restart and everything should work. If you still have problems try enabling/disabling windowed mode, sync and multi target.
Post edited June 14, 2018 by DF1871
I'm having the same problem. I've tried mutiple resolutions, full screen and vsync on and off and running in compatibilty mode, all with no luck. Has anyone else found a fix for this?
Installed a different version, 1.05 (DLC) instead of 1.05 (A), and that seems to have fixed it. I'll update this post if anything changes.

Edit: So far the game works perfectly installed on an older Windows 7 PC but running in Windows 7 compatibilty mode on 10 doesn't fix the problem.
Post edited October 10, 2018 by eaglescoutdjb