It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
avatar
LiefLayer: Just grab the old cider wrapper here:
http://portingteam.com/files/file/7163-dragon-age-origins-steam-version/

install the game on a windows virtual machine and configure it with the settings you want (screen resolution etc...)
copy the Bioware/Dragon Age folder from Documents folder on windows to Documents folder on mac.
copy the game folder inside Program Files folder in the wrapper
rename the folder from Dragon Age Origins to dragon age
change the Info.plist file inside the wrapper from
c:\Program Files/Dragon Age/bin_ship/revloader.exe
to
c:\Program Files/Dragon Age/bin_ship/DAOrigins.exe

if you need any help just ask me.

I think (not 100% sure) that the portingteam port is the old cider official port from the retail version.
Also I played the base game with it without any problems.

PS. remember that if you want to use wine on mac (this is not the case) you just need to use wineskin instead of plain wine... and that portingkit app and portingteam website contain many premade wrappers.

PS2. Also there is a crack inside the portingteam wrapper, but you don't actually need it with the gog version.
Just remember that what you download from portingteam are just wrapper (not games) and to make steam version work sometimes they include crack (the steam client port is a recent thing).
Can you also explain how to change to an other language than english?
Post edited December 04, 2016 by Silverhawk170485
avatar
Silverhawk170485: Can you also explain how to change to an other language than english?
sure, it is really easy you just need to go to:
~/Documents/Bioware/Dragon Age/Settings

open DragonAge.ini with a text editor
change
[GameOptions]
Locale=it-it
VOLanguage=en-us

to your language

(example
Locale=de-de
VOLanguage=de-de
since you are from germany you can change the voice over too).

gog version should have all the language in one package.
avatar
Silverhawk170485: Can you also explain how to change to an other language than english?
avatar
LiefLayer: sure, it is really easy you just need to go to:
~/Documents/Bioware/Dragon Age/Settings

open DragonAge.ini with a text editor
change
[GameOptions]
Locale=it-it
VOLanguage=en-us

to your language

(example
Locale=de-de
VOLanguage=de-de
since you are from germany you can change the voice over too).

gog version should have all the language in one package.
Thanks it worked. :)
For anyone interested in running the GOG version of Dragon Age: Origins Ultimate Edition on a Mac, Paul the Tall's Porting Kit (from PaulTheTall.com) has posted a wineskin wrapper that installs the game and runs very well on my 2013 Retina MacBook Pro (with Intel IRIS graphics). I purchased the GOG version for $10 a few weeks ago, and Paul came through on the port when I asked nicely;-) Smooth gameplay at medium textures, and the only tweak I needed to make in wineskin settings was to allow the Mac driver to override the Windows one (otherwise I had the cursor fade out every few minutes). I've played to the end of Korceri Wilds so far--very very pleased with this port. Well done, Paul!

Regards,

Dan