It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I know where to change language, however, changing these settings only affects basic Origin and Awakening campaign - it does not affect DLCs. How to change language in DLCs? (I know the translation of the particular DLC does exist in the language I need.)

-------------------
Update: PROBLEM SOLVED.
Post edited July 11, 2019 by Gnon_Uthersson
No posts in this topic were marked as the solution yet. If you can help, add your reply