It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I've created a support ticket but it's been several days without a response so I'm trying my luck here. Posting to see if there are others that are having or have had this issue in the past.

My problem is that one file in particular keeps failing the integrity check when trying to install. I've re-downloaded the file several times (5 downloads at least - 4GB file) via browser and also using a download manager but I still come up with the same issue. I've read suggestions such as disabling anti-virus and checking to see that the file has fully completed downloading (in case it's failed somewhere along the way), however it either doesn't apply to my case or doesn't work. I've also tried installing the game without doing an integrity check in case of a false positive but that doesn't work either. Also the whole reason I use GOG is so that I don't have to install a game client, so I'd like to resolve this without resorting to installing Galaxy.

I'd appreciate any suggestions and just in case a staff member happens to see this then my ticket ID number is 274304.

Thanks in advance.
No posts in this topic were marked as the solution yet. If you can help, add your reply
Just a quick update to my issue. I received a response from GOG support stating that they'd checked the file on their end and everything was fine along with some instructions on other ways to download the file in question.

What worked for me in the end was downloading the file from a different browser (probably irrelevant) with a different download manager (probably the reason the download succeeded this time). This time around I watched the download when it got near the end (99% and 3997MB of 4000MB downloaded) and saw the transfer rate drop to 0KBs for at least 2-3minutes before picking up again and finishing the download. I'm assuming that when this happened the previous times the browser and the first download manager thought the file had completed downloading and cut it off a few MBs short, which is why the file rightly appeared as corrupted during the integrity check.

I'm not sure why the download behaved this way for this one file but in the end the game installed and launched without a problem. I hope this helps anyone else who may come across this issue.