It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I can't find a tutorial on to do it. There is no "settings" folder?
avatar
larrymyster: I can't find a tutorial on to do it. There is no "settings" folder?
There are a couple of ways you can. The easiest way is to right click on your desktop shortcut, go to the properties tab, then add -enabledevelperconsole in the target box.

The other way is to go to the "data" folder in the main dragon age install directory and open the "DAOriginsLauncher.xml" file.

Replace line 180 with
<true action="execute" file="${BINARIES_DIR}\DAOrigins.exe" arguments="-enabledeveloperconsole;" path="${BINARIES_DIR}" autoquit="true" />
Post edited July 21, 2016 by coryrj1995
avatar
larrymyster: I can't find a tutorial on to do it. There is no "settings" folder?
avatar
coryrj1995: There are a couple of ways you can. The easiest way is to right click on your desktop shortcut, go to the properties tab, then add -enabledevelperconsole in the target box.

The other way is to go to the "data" folder in the main dragon age install directory and open the "DAOriginsLauncher.xml" file.

Replace line 180 with
<true action="execute" file="${BINARIES_DIR}\DAOrigins.exe" arguments="-enabledeveloperconsole;" path="${BINARIES_DIR}" autoquit="true" />
After that you must go into the keybindings.ini file usually located in "My Documents\BioWare\Dragon Age\Settings\" Find the line "OpenConsole_0=Keyboard::Button_GRAVE" (change GRAVE to any key not used in the game.)
Post edited October 07, 2018 by H1313303
I have "doctored" the short cut AND the "DAOriginsLauncher.xml" file.
And in the "keybindings.ini file" I changed the word "GRAVE" to just the letter "y".

And once in the game i can open the console and type"y".... BUT .... when I then press enter I get an error message that says the function is not recognised .... nor can I close the console OR exit the game.

Can you please assist ??

I am not technically gifted and will need clear and simple instructions, please.

Thanks.
avatar
Bean1eMad: I have "doctored" the short cut AND the "DAOriginsLauncher.xml" file.
And in the "keybindings.ini file" I changed the word "GRAVE" to just the letter "y".

And once in the game i can open the console and type"y".... BUT .... when I then press enter I get an error message that says the function is not recognised .... nor can I close the console OR exit the game.

Can you please assist ??

I am not technically gifted and will need clear and simple instructions, please.

Thanks.
Hey man, i'm here. I got it to working and will explain how.

First, you don't have to change your key. Or alter those lines. I don't know why it was suggested, but it is bullshit.

I take it you have the mod for console visibility installed. If not, do that.

I also suggest to reverse the changes you made.

All you need is:

A shortcut with -enabledeveloperconsole at the end (with one space from the last letter,
so: blablabla -enabledeveloperconsole

Just to check; have you made the shortcut directly from the exe file? not the shortcut gog gives you. Go into the directory and make a shortcut from the normal exe. Then apply the -enabledeveloperconsole to that.

This should work. I hope it does. I did it like this, with gog's ultimate edition and it worked. Laptop, windows 10. Let me know.
avatar
Bean1eMad: I have "doctored" the short cut AND the "DAOriginsLauncher.xml" file.
And in the "keybindings.ini file" I changed the word "GRAVE" to just the letter "y".

And once in the game i can open the console and type"y".... BUT .... when I then press enter I get an error message that says the function is not recognised .... nor can I close the console OR exit the game.

Can you please assist ??

I am not technically gifted and will need clear and simple instructions, please.

Thanks.
avatar
fighterkill: Hey man, i'm here. I got it to working and will explain how.

First, you don't have to change your key. Or alter those lines. I don't know why it was suggested, but it is bullshit.

I take it you have the mod for console visibility installed. If not, do that.

I also suggest to reverse the changes you made.

All you need is:

A shortcut with -enabledeveloperconsole at the end (with one space from the last letter,
so: blablabla -enabledeveloperconsole

Just to check; have you made the shortcut directly from the exe file? not the shortcut gog gives you. Go into the directory and make a shortcut from the normal exe. Then apply the -enabledeveloperconsole to that.

This should work. I hope it does. I did it like this, with gog's ultimate edition and it worked. Laptop, windows 10. Let me know.
Confirmed. Adding the -enabledeveloperconsole to the text line in the Target box in "Properties"(right click shortcut) works, but only with the shortcut found in the bin_ship folder. The shortcut which works for me is the one with the blue Grey Warden griffon symbol on a golden kite shield, not the red dragon icon. For some reason, the red dragon icon shortcut is the one placed on the desktop during installation so at first I assumed it would work to add the extra text to the target box in "Properties" of the red dragon icon shortcut, but it only works with the blue griffon shield icon shortcut. At least that is how it worked with my machine.
I did the change using the DAO launcher in the bin folder ( blue one)and got the nexus mod for console visibility changed the key to the letter y as a try too.and nothing.
I even tried the change line in data folder too..

Is the GOG version so different or and update changed thing? please help.
avatar
Longshot338: I did the change using the DAO launcher in the bin folder
Don't use the launcher shortcut.
In the ...\Dragon Age\bin_ship folder, right click on daorigins.exe and select Send to > Desktop (create shortcut.) See Pic: (exe.jpg)

Then right click on the new desk top shortcut, Properties, At the end of the target field, after daorigins.exe" leave a space, and then add -enabledeveloperconsole See Pic (shortcut.jpg)

You don't need to change the tilde key if your using a US qwerty keyboard.
Attachments:
exe.jpg (253 Kb)
shortcut.jpg (76 Kb)
avatar
Longshot338: I did the change using the DAO launcher in the bin folder
avatar
olnorton: Don't use the launcher shortcut.
In the ...\Dragon Age\bin_ship folder, right click on daorigins.exe and select Send to > Desktop (create shortcut.) See Pic: (exe.jpg)

Then right click on the new desk top shortcut, Properties, At the end of the target field, after daorigins.exe" leave a space, and then add -enabledeveloperconsole See Pic (shortcut.jpg)

You don't need to change the tilde key if your using a US qwerty keyboard.
I did that. I used the exe launcher in the bin folder, the one with the blue dragon on the gold shield. and no joy.
avatar
Longshot338: I did that. I used the exe launcher in the bin folder, the one with the blue dragon on the gold shield. and no joy.
Next question, did you use Angel console fix ? https://www.nexusmods.com/dragonage/mods/1110?tab=files
To make the commands visible, without it, nothing appears to happen when you hit the tilde key.
If you hit the tilde key, can you still move your player character ?
If not, it means the console is working, and you just can't see anything without the font fix, or you installed the font .erf in the wrong place.
It goes in C:\Users\Username\Documents\BioWare\Dragon Age\packages\core\data See Pic (fontserf.jpg)

If pressing the tilde key, or the y key if you still have it changed, doesn't stop you from moving your player character, can you post a pic of your shortcut target field like shortcut.jpg above.

Edit: I re-read you first post and see you installed the missing font.
Attachments:
fontserf.jpg (135 Kb)
Post edited October 28, 2019 by olnorton
I used the GOG verify file to reset the game.
the key binding stayed at my setting of y.
the Fonts .erf file stayed where it said to go.( unpacked with 7zip)
I left the launcher be as far as using the shortcut change.
I did the line 180 change to the launcher.xml file on notes++. The blue & gold one in the bin_ship folder.
Launched the game direct from the folder as a try. Game ran ( full screen if it matters), hit y: no console.
no indication of fonts, no console box/window and the game runs normal.
could the ERF file be so out of date as to not be usable any more? Also why does the change not work? I followed EXACTLY as posted

EDIT: For the heck of it I did the short cut change to the GOG launcher, still with the above changes AND NOW I see in the upper left corner over the top picture a > and now type see text..
Post edited November 01, 2019 by Longshot338
avatar
Longshot338: I did the change using the DAO launcher in the bin folder
avatar
olnorton: Don't use the launcher shortcut.
In the ...\Dragon Age\bin_ship folder, right click on daorigins.exe and select Send to > Desktop (create shortcut.) See Pic: (exe.jpg)

Then right click on the new desk top shortcut, Properties, At the end of the target field, after daorigins.exe" leave a space, and then add -enabledeveloperconsole See Pic (shortcut.jpg)

You don't need to change the tilde key if your using a US qwerty keyboard.
Thank you!!

Been trying all the other things from all over the web. This one is the key!
I tried the methods listed on this page, and none of them worked for me. The simplest of which, adding -enabledeveloperconsole should have worked but didn't. Long story short, my poor eyesight and copying/pasting the bold version in the second post to save time did me in. It is misspelled. After realizing and correcting that, it works as expected.
Post edited January 28, 2020 by thainej6
avatar
fighterkill: Hey man, i'm here. I got it to working and will explain how.

First, you don't have to change your key. Or alter those lines. I don't know why it was suggested, but it is bullshit.

I take it you have the mod for console visibility installed. If not, do that.

I also suggest to reverse the changes you made.

All you need is:

A shortcut with -enabledeveloperconsole at the end (with one space from the last letter,
so: blablabla -enabledeveloperconsole

Just to check; have you made the shortcut directly from the exe file? not the shortcut gog gives you. Go into the directory and make a shortcut from the normal exe. Then apply the -enabledeveloperconsole to that.

This should work. I hope it does. I did it like this, with gog's ultimate edition and it worked. Laptop, windows 10. Let me know.
avatar
LesTyebe: Confirmed. Adding the -enabledeveloperconsole to the text line in the Target box in "Properties"(right click shortcut) works, but only with the shortcut found in the bin_ship folder. The shortcut which works for me is the one with the blue Grey Warden griffon symbol on a golden kite shield, not the red dragon icon. For some reason, the red dragon icon shortcut is the one placed on the desktop during installation so at first I assumed it would work to add the extra text to the target box in "Properties" of the red dragon icon shortcut, but it only works with the blue griffon shield icon shortcut. At least that is how it worked with my machine.
I just wanted to say this is what worked for me. I tried to do it via the shortcut GOG creates for you and places on your desktop but it wasn't working. Doing it with the launcher found in the bin_ship folder did the trick for me.