It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I tried all the possible solutions (WineD3D, 8bit colour restriction, dgvoodoo) but nothing worked.

Got it to run by going into the dracula3.exe file, under settings for all users

-set comp mode to XP SP3
-activated "deactivate full screen effects/enhancements" left everything else deactivated!!!
-set fullscreen to 1 in the config.ini

game suddenly worked