It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I don't know if this also applies to the GOG version of "Dracula Resurrection", as I don't own this version yet. I had the problem with the retail issue of this game, as part of the German "Dracula Trilogie", that the cutscenes were running too fast. I've found a solution recently. Seems that the problem of slowly running cutscenes and sound stuttering is just the opposite to the one I had, so the solution may be similar.

Here is the thread I've published in various forums:

For those who still have a problem with the reissue of "Dracula Resurrection", the game version allegedly compatible with newer PCs, because the cutscenes are running much too fast, I have a solution here. I'm referring to the version from the German "Dracula Trilogie", this is the one I've tested, but hopefully this also works with other language versions.

I've found this solution after a long period of trial and error, which already drove me to desperation. Neither a software that slows down the PC nor restricting the game to a single processor core (the hyperthreading issue) nor installing an older graphics card driver worked for me. Only the following procedure, that looks a little elaborate, but is done quickly. As I checked, it equally works under Windows Vista 32-bit and Windows 7 64-bit.

Download the software DXWnd from the Sourceforge website (just google for it). It's besides worthwhile to look out for the newest version from time to time.

After starting the program - CAUTION: preferably don't run any other programs at the same time, especially not the Internet Explorer, as these are likely to crash due to DXWnd - create a new profile for Dracula Resurrection: Edit -> Add -> navigate to Dracula.exe under "Path". Choose under "Name" a name for this entry, e.g. "Dracula Resurrection". On the various tabs, that always can be accessed by: highlighting an entry in the profiles list, right click -> Modify or Edit -> Modify, there are then certain parameters to adjust - the most important first: on the tab "Timing" click "Limit" and enter a value of 50 milliseconds for instance under "delay (msec)". That helped for me, video and audio of the cutscenes are running without any flaws now. If there persists a lack in quality, just experiment a little with this value. This action, by the way, has no negative impact on the rest of the game.

Actually DXWnd is primarily conceived to run software in a window that otherwise runs fullscreen. If you use other settings than the ones mentioned here that also works for Dracula Resurrection, at least with the restriction only however that once being in the main menu the mouse cursor can't get out of the game window any more. To play the game as originally intended in fullscreen, to further set the following preferences is advisable: on the tab "Main" click "Desktop" (for the method used here it doesn't matter what you fill in next to it under "Window initial position & size"), also under "Window" "Keep aspect ratio" (to avoid that during gameplay the picture gets distorted, when suddenly the display changes to widescreen, due to an occurring Windows error message, stating that as described another program has crashed) and under "Mouse" "Hide cursor".

What moreover is at least to be activated is under "Main" "Hook enabled", set under "DirectX" "DirectX Version Hook" to "Automatic" or "DirectX 1~6". If you don't want the DXWnd logo to show up (what it only occasionally does) when the hooked program starts, under "Main" click "No banner". Preferably deactivate all the other adjustments or leave it on the default option or value.

When closing DXWnd and changes are made like the indicated entry, you'll be asked whether to save them, confirm this.

In order that playing in fullscreen works, this is what you have to do finally: right-click the file Dracula.exe or a shortcut to it, go to "Properties" and under "Compatibility" check "Run in 640 x 480 screen resolution". (The game also runs normally under no other than that resolution.)

What is important too: No "Windows 95" or "Windows 98 / Windows Me" must be set under compatibility mode, as well under Windows 7 no "Windows XP (Service Pack 2)" or "Windows XP (Service Pack 3)"!

If now the game is started in DXWnd by right-clicking the entry -> Run or Edit -> Run, then all cutscenes should at last run in normal speed.

If you don't want to start the game via DXWnd all the time, you can also build the following batch file:

@ECHO OFF
START "" /D "C:\DXWnd" "C:\DXWnd\dxwnd.exe" /T
TIMEOUT /T 5 /NOBREAK >NUL
"C:\Dracula 1\Dracula.exe"
TASKKILL /IM dxwnd.exe >NUL

Adapt the file paths in line 2 and 4 to your own ones. Should the changes that DXWnd does take no effect, you may have to define a higher waiting time than 5 seconds in line 3.

Certainly I can't guarantee that this works for all PC configurations. I hope however that it helps one or the other.
Post edited December 14, 2013 by SpiRec
Worked perfectly, thanks a lot! :D
Didn't work for me. Windows 8, 64 bit, Dracula Resurrection (German Version).
First it didnt work for me too, but i have do the following extra thing:

Just check under Compat/ the option "Set Single Core Process Affinity" and now it is working all fine!
I realized that I can't follow your suggestings one to one because some stuff is moved to new register cards of DXWnd at the top. Maybe the version changed quite a lot compared to the one you were using.

Nevertheless I did all the stuff you mentioned but the dracula.exe is not working anymore if I start the game with DXWnd. I am using Win10 64bit. I also tried to run the game without changing a thing to evalute where the errorr is. Same effect. Not running.

What do you mean with:
"What is important too: No "Windows 95" or "Windows 98 / Windows Me" must be set under compatibility mode, as well under Windows 7 no "Windows XP (Service Pack 2)" or "Windows XP (Service Pack 3)"! "

Is it the Windows compatibility mode of the .exe or the one in DXWnd?

Any help is welcomed!
avatar
Goosman123: I realized that I can't follow your suggestings one to one because some stuff is moved to new register cards of DXWnd at the top. Maybe the version changed quite a lot compared to the one you were using.

Nevertheless I did all the stuff you mentioned but the dracula.exe is not working anymore if I start the game with DXWnd. I am using Win10 64bit. I also tried to run the game without changing a thing to evalute where the errorr is. Same effect. Not running.

What do you mean with:
"What is important too: No "Windows 95" or "Windows 98 / Windows Me" must be set under compatibility mode, as well under Windows 7 no "Windows XP (Service Pack 2)" or "Windows XP (Service Pack 3)"! "

Is it the Windows compatibility mode of the .exe or the one in DXWnd?

Any help is welcomed!
Sorry for my very late response. I wasn't aware of your post earlier. I am afraid I can't really help you, as I don't have Windows 10. Theoretically, it also could be the version of DXWnd that you are using that is causing the trouble. The version that I used to find a solution (version 2.02.39) is outdated for a long time already.

The compatibility mode setting I mentioned is the one of the Windows shell (under "Properties"), not the one in DXWnd.
Post edited August 29, 2018 by SpiRec
I tried the dxwnd fix but did not manage to get the game to work with dxwnd at all.
So after I tried several settings on dxwnd I decided to use a much more simple approach which worked to my surprise perfectly.

I used MSI Afterburner and Riva Tuner Statistics Server (which is an optional downlaod) when downloading MSI Afterburner and simply limited the FPS to 30. Game runs without a hitch now. No skipping and everything runs with the correct speed.

Using nvidiainspector and limiting the FPS to 30 also works - unfortunately though you need to have an nvidia card if you like to try this tool.
Post edited September 30, 2018 by MarkoH01