It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Dear Gog team and fellow players:

I am surprised that after this long, this simple fix has not been applied for the installation. Perhaps Gog team could kindly modify the Installation soon?

To succesfully launch the game, go to the game folder of Dracula 2, and launch game.exe instead. If you try to launch the game from the default shortcut, you will get an error pop up message that says "The files for the Autorun have not been burned to CD/DVD correctly."
avatar
kittyteddy: Dear Gog team and fellow players:

I am surprised that after this long, this simple fix has not been applied for the installation. Perhaps Gog team could kindly modify the Installation soon?

To succesfully launch the game, go to the game folder of Dracula 2, and launch game.exe instead. If you try to launch the game from the default shortcut, you will get an error pop up message that says "The files for the Autorun have not been burned to CD/DVD correctly."
addendum:

sometimes the game.exe needs to be renamed to its original filename: fvr_viewer.exe

cheers
avatar
kittyteddy: Dear Gog team and fellow players:

I am surprised that after this long, this simple fix has not been applied for the installation. Perhaps Gog team could kindly modify the Installation soon?

To succesfully launch the game, go to the game folder of Dracula 2, and launch game.exe instead. If you try to launch the game from the default shortcut, you will get an error pop up message that says "The files for the Autorun have not been burned to CD/DVD correctly."
On win7 it worked for me to disable compatibility mode on dracula2.exe. Game works fine and can be started with Galaxy as well this way (which is not possible when renaming executable).