It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I upgraded to Windows 10 and the past two games I have installed via Galaxy would not run, until certain fixes were applied.

The Visual C++ Redistributable Package you are shipping with DD is version 2012. I had to install version 2013 in order for the game to run. Can be found here:

Terraria was another game that would not work due to XNA not being installed via Galaxy. Both games were caused by issues in the _redist folder, which leads me to believe, they have not been updated to support WIndows 10.
The link in the original post downloads vcredist_arm.exe which I think is for phones, here is the page where you can choose the x86 or x64 version I don't own the games mentioned so I have tried this fix.
I can't get the game to play either. When I launch game, it says it can't find the MSVCR120.dll. It suggest reinstalling, but that didn't help either. I tried downloading from the two links in the other replies, but that didn't fix my problem either.

Edit-- I downloaded the wrong file. I needed the 86 file instead of the 64. The game plays now. Thank you for the help.
Post edited July 03, 2017 by KSingle01