It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Tl:dr - I didn't like it!

Recently, I wanted to play something "light-hearted".
You know: something that doesn't claim hours of your life, only to get from "level 1 " to "level 2".

And since - not too long ago - I had claimed "Doors: Paradox" on the EGS for free, I thought:
"why not give this little puzzle game a chance? Seems nice enough."

Boy, am I glad I didn't spend money on this!

At first, it really seemed to be a nice little time-waster (though I quickly became weary of those nonsensical scrolls, that each puzzle had to offer).

But, soon enough, unnecessary steps started to annoy me.

Let's say: I solved a puzzle, and that opened a flap.
And under that flap was a keyhole, for which I already had the fitting key in my inventory.
Now, the logical next step would be to take the key from the inventory and drag it onto the keyhole, right?
Nope! Not in this game.
Because this game zooms out of every puzzle, as soon as you have solved it...and you can't e.g. drag a key onto a keyhole, without zooming in again, first.

Why? Oh why?

Next annoyance: some inexplicable flaws in the logic of the game.

Usually, you would have a pretty good idea, as to what exactly a certain puzzle requires you to do, to be solved.
There may even be one or two - more or less - clear hint(s) to it.

However - I stumbled over a few puzzles, whose solutions apparently didn't follow any logic, one could have been come to, by playing the game.
So, you had to find a solution - which didn't follow the logic, prevalent in the rest of the game.

In a puzzle game, that's a no-no for me.

At other times, you sat before the screen, after trying everything you thought, you could try - only to find, that one can do something on the screen (which is not hinted at), and which - at any other opportunity/puzzle - would not have achieved any result...again: an absolute no-no for me.

I think, the game has 66 puzzles?
I played through chapters 1 (Awakening) and through most (to puzzle18 or 19?) of chapter 2 (Origins).

At that point, I had finally reached the end of my patience.
This little stinker had already taken up too much of my time and goodwill.

Stopped playing mid-puzzle, de-installed it, and will never install it again.