It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

So I played DOS 2 DE a couple days ago, and decide to play again today, but unable to. GoG Galaxy keeps trying to update but cant and is on an infinite loop, failing. Anyone have a possible solution or is this happening for most/all users? Thanks in advance, my latest patch is
Post edited September 16, 2018 by Kojerko787
No posts in this topic were marked as the solution yet. If you can help, add your reply
-I have similar issue.
Game updated, marked as installed, but button to play is greyed out.

Update was done from Gog Galaxy from original sin 2 to OS2 definite edition, 29 Gb downloded ok.

Also, tried to select French language, but it keep revering to english.
Downloaded fresh version but can´t start the game even the button is green. (Version
Tried the goggalaxy launcher, desktop link or the start.exe also with admin. Nothing works so far
Post edited September 19, 2018 by Gasbic