It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

When I try to load my game, I get errors stating that the game was unable to delete the level cache files.

If I delete them myself, then try to load the game, I get an error stating "server shutting down"

In case anyone else has this issue, here is the solution from RAZE (Larian Support):

Can you load older saves?

Are you shutting down all non-essential programs before starting the game, especially anti-virus and any backup programs that may be monitoring the My Documents folder?
For example, a few people have had BitDefender block the game from being able to create files and folders, which has caused the these errors. In that case, including both the game executables and Larian Studios My Documents folder in BitDefender's trusted app and directory sections should fix the problem (Advance Threat Defense, Ransomware Protection / Safe Files, Application Access).
Windows Defender has also caused this problem; in that case an exception for the game can be made in Start, Settings, Updates & Security, Windows Security, Virus & threat protection, Virus & threat protection settings, Add or remove exclusions.

Try exiting out of the Steam client, if applicable, and starting the game directly from the '..\SteamApps\common\Divinity Original Sin 2\DefEd\bin\EoCApp.exe' program file, by right clicking and running as administrator.

Try creating a new Windows administrator user account (either with the My Documents folder in the default location, or on a different drive, if available), switch to that account and try starting the game from there, directly from the executable. If that lets you start a new game and save/load, try exiting, copy a save folder from your current user account's My Documents folder, and see if you can load it.
Each save is a folder in the '..\Documents\Larian Studios\Divinity Original Sin 2 Definitive Edition\PlayerProfiles\<ProfileName>\Savegames\Story' folder.

Try doing a clean boot and then test the game. Click Start, or hit WinKey-R, type in msconfig and hit enter; in the General tab, click Selective Startup, uncheck Load startup items (if required) and leave Load system services and Use original boot configuration options checked. Next, click on the Services tab, check the box to Hide all Microsoft services, then click the Disable All button (maybe make a note of which are currently enabled/disabled), then click OK and reboot the computer.
Run msconfig again to switch back to the normal boot configuration.
Post edited September 22, 2018 by cjmizanin