It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I've just purchased the Definitive Edition from GOG.

How can I start it without GOG running?

In the case of Baldur's Gate 3, it was just a matter of making a shortcut to the correct .exe, but I'm not sure which one to use?

The launcher I can easily find is a shortcut to "D:\GOG\Divinity - Original Sin 2\bin\SupportTool.exe".

When I run that, I get a screen with a GOG logo offering registration for a Larian account (which I don't want).

Entering "Skip", choosing Definitive Edition and Play results in CTD.

Is there a better way to launch?

(Apologies if this has been asked a thousand times).

P.S. Crash to desktop happens even if GOG client is running.
Post edited January 16, 2024 by Proleric
From the log file, it seems that the standalone .exe is "..\defed\bin\eocapp.exe".

This crashes even if run without GOG or the launcher, with no further log info I can find, so I guess it's a Larian problem.

Correction - if the game is launched from GOG Galaxy, the game launches as far as Select Player Profile.

Edit - I can create a character and save the game.

If I quit, the game will still not launch standalone.

Edit - on further examination, it looks like eocapp.exe standalone is crashing while trying to display the Larian logo.
Post edited January 16, 2024 by Proleric

In order to get DOS2 to run standalone, it was necessary to delete (or rename) galaxypeer64.dll from all subfolders of C:\ProgramData\\Galaxy\redists\peer.

Windows Event Viewer identified that .dll as the source of the crash.

In other forums, I read that this is a known issue for DOS2 and some other games.
Yeah, I was just coming in here to post about this or see where else to report the issue. I wish I'd found this thread before going through every other conceivable solution.

With the .dll fix, you lose cloud saves/multiplayer for all GOG games, but by running it exclusively through Galaxy, you kind of lose out on the DRM-free aspect.
Haven't tried it through website version of the offline installers, as downloading it just once took about two weeks with my connection speed.
Post edited January 18, 2024 by CaptainWolfers
Positive update!

Another (bad) fix I've found is that the launcher and .exe work just fine when fully offline.
More importantly, though, a number of other threads have pointed to this bug with OpenSSL being the culprit:

Fix summary if the page makes your eyes cross like mine-
Go to Settings > System > About, click on "Advanced system settings" and then the "Environment Variables" button on the "Advanced" tab.
Under the lower box, click "New" and create a new variable named "OPENSSL_ia32cap" with a value of "~0x20000000".
That's seven zeroes after the two, and of course no quotation marks in either field.

After doing this, I booted the game five times in a row without issue. Once through the launcher shortcut, once with EoCApp.exe, both again after a restart and once more through Galaxy. Saves were started, quit and loaded without issue, and each time the multiplayer menu showed available games.
I haven't played long enough to be 100% certain this fixed it, but fingers crossed.

I've submitted a ticket to report this. It seems to cause problems for other isometric RPGs as well, such as Tyranny.
Post edited January 18, 2024 by CaptainWolfers