}

It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Not sure when it happened or how, but I go in and noticed things were a little sluggish. No problem, just check my screen resolution: 3840x2160, wait what? I set it at 1920x1080. Go to change it, and no other options are presented, just the one.

Hmm, Nvidia control panel, it recommends 1920x1080 also, tell it to "optimize", restart, again, too high, only one option. Dig out the XML file to edit with the options. Set that, save it, restart, same thing, and yes, things remain sluggish and look like they really are still that high a resolution.

I've seen a few similar posts claiming this and the best answer suggested was "change your desktop resolution", which is a fancy way of saying "I have no idea, go away." Any suggestions or is this just a bug that the devs have no option to solve (in other words, play another game for the next six months and hope it is fixed by then)?


Windows 10
Nvidia GTX 1050
Drivers current (did an update to be certain)
No posts in this topic were marked as the solution yet. If you can help, add your reply