It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I just got the Elven Seer bug where neither Saheila nor Tovah will talk with you after returning Saheila from the sawmill.
The online work around was to fail at steeling from them and then it would continue the quest, but I can't pickpocket Saheila, even in sneak mode the only options are examine & attack.
I could fail at pickpocketing Tovah, but then my only dialogue option was "what did you want me to do again?"
She then explained I needed to rescue the daughter standing in front of her. (I guess we know where Saheila gets her blindness from.)

I tried going back a couple of hours from before I first entered the Elven camp, but I got the same result.

One of the change logs says this bug was fixed, but as of version it is not, and given I'm playing an Elf and have Sebille in the team, this is quite an important quest to fail.

I tried to register on the Larian forum to report it there, but so far I haven't received the confirmation email, so hopefully someone from Larian will see this here.

Talking to Tovah didn't advance the quest, but it did allow me to fail at pickpocketing Saheila,(or maybe it was just that I had shut the game down and reloaded.) anyway, after getting caught by Sahelia, and bribing her, I was able to talk to her again and get the Sebille tree mother bit, and again to finish the Elven Seer quest.
Post edited November 09, 2018 by olnorton