It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

So I don't really want to use Galaxy and don't care how big these games can get as offline installers.

Unfortunately, the installer for Dishonored 2 seems to be broken? The third file (setup_dishonored_2_1.77.9_(36134)-3.bin) doesn't pass the installer's integrity check. I've tried re-downloading the offending file, and then re-downloading the entire installer, and I still get this error regarding this exact file. I don't think this is a problem on my end.
This question / problem has been solved by SKARDAVNELNATEimage
pbaggers: I still get this error regarding this exact file. I don't think this is a problem on my end.
I think it probably is, or it would be corrupt for everyone.
Try clearing your browser cache, or before re-downloading the offending file, rename it, and then change it back after it downloads.
You could check the BIN file's hash to see if it matches those from other users. I've been using wget (command-line tool) to download these since it checks for read errors and allows continuing more reliably than browsers.

Haven't installed's version of D2 yet (still downloading the parts every so often) but my hash of that same file is the following (using the SHA-256 algorithm):


There are GUI-based checksum programs available but if one wants something already in Windows I made a command-line command that can be used to check.

for /f "delims= skip=1" %a in ('certutil -hashfile "setup_dishonored_2_1.77.9_(36134)-3.bin" SHA256 ^| find /V "CertUtil:"') do @echo off & set "h=%a" & echo | set /p=%h: =%| clip & @echo on

See the attached GIF for how to run this in the folder containing the file (only works in folder paths without special characters/Unicode).

The command uses the Windows in-built certificate utility tool ('certutil') to list a hash of the file using the SHA-256 algorithm. The 'for' loop skips the first unnecessary line of the output, then 'find /V' returns all text excluding the last line, leaving just the hash. The spaces are then trimmed and it copies the hash to the clipboard.

Process will take a minute or so before it completes for the large BIN files. Change the filename to whatever filename is in the directory (above looks for the '-3.bin' file).
example.gif (245 Kb)
Post edited February 23, 2020 by Coreda
The SHA-256 hash for the offline installer number 3 bin is CFC7A0CED2D39AAD11FFDDE466C703F9224164BF6C92A2CA2378F243FC275D64

But if it doesn't pass the verify test then it won't be right.
Are you shure the File is really -3.Bin, because the third file is the one with -2.Bin (the Starter-exe is 1 and then it starts with -1.Bin as 2). Just for being sure you dont replaced the wrong file...
Post edited February 23, 2020 by Foggerle
Damn. I really am the only one here, right? And yeah, I'm talking about the file ending in 3 (but is considered part 4 of the overall installer).

I tried renaming the file before downloading it -- then renaming it back. Didn't work. I'll look into the other solutions posted when I have time. Thanks everyone for the help.

EDIT: Okay, I tried the hash method, I get the number 951e7415f5c508d5e05536fedcb413de412b3f5745c987a3fd4c6d1689554886 so something is clearly messed up on my end. When I get the chance, I'll try clearing my browser's cache and restarting my computer.
Post edited February 23, 2020 by pbaggers
pbaggers: Damn. I really am the only one here, right?
Not the only one. It's happened to me twice now. It's a huge download (I also don't use Galaxy), and I'm busy with other things, so I was going to wait to see whether enough of the same complaints roll in for GOG to check the files on their end. I'm sorry that I can't be of any technical help to you, but I wanted to let you know that it's not just you.
I'm also seeing issues with Dishonored 2 3.bin and Death of the Outsider 3.bin.
Post edited February 24, 2020 by SKARDAVNELNATE
Okay. That's three of us. Didn't know there was a similar problem with Death of the Outsider. Can't be a coincidence. Something to do with Denuvo's removal, perhaps? Dishonored 1 installs fine for me, and that originally only had Steam DRM.
Post edited February 24, 2020 by pbaggers
I've used GOGRepo to download the installer.
I've used Firefox and Chrome to download the 3.bin files independently.
Now trying GOG Downloader.

Update: Success with GOG downloader.
Post edited February 25, 2020 by SKARDAVNELNATE
SKARDAVNELNATE: Update: Success with GOG downloader.
Is GOG downloader even still a thing? I thought it was replaced by Galaxy.

My guess is that one or more of GOG's servers has a faulty file, or one or more of GOG's servers doesn't.
Post edited February 26, 2020 by pbaggers
SKARDAVNELNATE: Update: Success with GOG downloader.
So, what are the correct file hashes for all the installer parts (including EXE)?

Did everyone's failing file have the same hash as pbaggers had? If so, then that would definitively point to a corrupt/incomplete file on some of GOG's CDNs.
Gydion: So, what are the correct file hashes for all the installer parts (including EXE)?
Dishonored 2
a4 d8 bf 31 65 91 ff 48 57 8e 3f 1a aa 5e 7e 1d df b3 21 e5 01 a1 29 6b 49 bf c3 ef 5d 18 f2 fe

99 ef 85 8e d6 93 b3 aa 2c d5 af 96 47 c1 4d 4e 64 7e fb 8a 07 01 98 14 4e eb 28 43 c4 e8 63 50

99 8e 81 4e 1d 08 6c 62 50 a7 02 c3 39 a0 46 9b 3c 04 97 37 f0 23 79 ed b0 87 45 d8 73 da 29 f9

cf c7 a0 ce d2 d3 9a ad 11 ff dd e4 66 c7 03 f9 22 41 64 bf 6c 92 a2 ca 23 78 f2 43 fc 27 5d 64

60 eb f9 8f b5 c5 0a dc d6 d1 46 16 80 be 08 9f 7b f6 a9 ca 1e ab b5 f2 93 46 d4 94 e4 a6 9a 02

d1 8b 22 ea a4 18 30 6e 28 96 7e f7 77 87 92 ae e3 10 c7 67 8e d6 01 43 70 89 a8 18 2a 11 15 5b

cb c9 cf ea 59 e2 dd 5b cb a3 55 b4 e7 57 a7 f7 b6 a4 e5 28 ec ff d0 23 7c 87 80 13 58 fa 0c 9d

d0 18 88 8d f1 72 2c a1 f9 49 22 96 bc 43 27 43 04 d7 60 e3 1b 7a 14 ab bf 36 2f 0e ca 61 94 26

92 d9 6a 78 19 f8 79 70 c3 8b a2 89 63 79 4d 5b d0 f9 48 b3 93 13 79 d7 19 40 67 f2 9d 6c 65 f5

d1 ab b7 cb 10 9c 5d 4f 8b ba 0e 23 73 51 d6 95 6c a6 76 4d 91 6b a3 5c 3c 30 d9 ad 0f a3 87 8b

09 65 7e 13 36 d0 4c 0d 6e 6a 11 13 c7 a3 bf 49 14 b1 b0 14 4e 5e d6 08 1f 89 6b d9 c1 96 91 f7

Death of the Outsider
13 80 3c 0b ec 66 ea 64 89 e7 36 f6 26 ca aa 77 22 f9 97 fd 34 4e aa 6c 16 0b 9d db 2a d2 51 de

e0 ca 70 8e 01 65 4f 8c 09 c3 8e df 9e 29 3d 61 85 03 ff c5 62 9e 0c 46 1d 2e 5c d2 c9 80 37 7b

a9 ba 9f d0 24 5e d0 6d 67 83 02 8d 27 45 f1 b6 1b 1f 1d b1 98 5d 3f 78 15 f4 04 7c 10 7c b0 ce

e0 1d bd 8b 33 49 8b cb c4 1e 19 bd b5 3a 3c 2d 2a ab 70 24 35 25 2a 96 d5 a8 e8 52 d1 7a f8 8a

7f 9e 63 73 ea 20 22 fb 48 c1 d7 a7 06 0c 0d 03 45 1f ef 2a 42 5b bb a1 ef ee 39 c5 3e 56 e1 cc

6d 61 f8 85 96 66 41 c5 c5 49 7d ae 9f 6a 79 e2 7d 88 8a df 0a cc 88 af 17 ba aa 2d 9a b6 f2 a8

ac d9 80 b9 91 52 92 d1 06 57 50 fd 2b 05 18 f0 59 51 5c 9a ba 48 4c d7 2f 5a 33 00 7f 38 76 39
Post edited February 29, 2020 by SKARDAVNELNATE
Useful, cheers. Also if anyone is comparing their own hashes which lack spaces they can ignore the spaces in them here since it's irrelevant (except for making it more readable at a glance).
Post edited February 28, 2020 by Coreda
I downloaded the installer through GOG Downloader and am pleased to say that it now passed the integrity check. I'll mark this thread as solved, but this is really an issue with one or more of GOG's CDNs.

EDIT: Death of the Outsider installs just fine too.
Post edited March 01, 2020 by pbaggers