It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

high rated

"Failed to initialize Direct3D.
Make sure you have at least DirectX 9.0c installed, have drivers for your
graphics card and have not disabled 3D acceleration
in display settings.
InitializeEngineGraphics failed"


Like me, several more ppl have this same error msg, and arent able to play the game at all.
I have opened a ticket to try and solve the problem, also have asked to dev's for a solution.
So far the help from costumer center wasnt able to solve it, and no reply from dev's.

Since i also work on IT, decided to do some tests myself.
And so far i think i may have "solved" (workarround) it.

SOLUTION (workarround, doit on your own risk, im not a dev)

Apparentely the problem its related with/how the game calls the .dll
On mi 64b Win10, he dont "like" to use Directx9, but runs ok with Directx11

1 - Go to your game instalation folder (\Program Files (x86)\GOG\GalaxyGames\Diluvion)
2 - You will find there several .dll including d3d9.dll and d3d11.dll
3 - Rename the d3d9.dll to something else like #d3d9.dll
4 - As so, the game will use the d3d11.dll

After this change i was able to play/run the game with no problem at all.
PS - Sorry mi english, its self learned...

Best regards,
Post edited February 08, 2017 by trev2000
Hope this solution/workarround help other with same problem.
hi trev2000

your solution works.

well done
thank you
Post edited February 08, 2017 by Etaine
Etaine: your solution works.
Nice to know that :)
Just as curiosity, whats your OS version?
Etaine: your solution works.
trev2000: Nice to know that :)
Just as curiosity, whats your OS version?
I'm using Windows 10 64bit
(exact version is 10.0.14393.0)
Works for the same error in Oxenfree as well - just renamed the d3d9 dll to d3d11, and all good. Well done!
Nice.... works for me too!
Works like a charm.
Good work Trev!
This is surprisingly still an issue. Thanks for the solution, got Oxenfree for my girlfriend for christmas and haven't been able to play it it'll now!
Thank you so much for posting this Trev!
Thank you so much, trev2000! I have been at a dead end with this issue and Google or Steam Community is not reallly helpful.

The workaround is awesome and I think it's probably the main issue, so I think I could blame the game developers for this.

As many people here, my problem was with OXENFREE game.

Thanks again.