It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
This game is very nice and I appreciate it.
I hope this game-play feedback will reach the developers.

---

Bug #1:

it is possible to "recall" a dice from a task it was assigned to.
That can be done by alt+click on the dice, free alt, click on the dice.
While that itself is probably intended behaviour for cases when you miss-clicked, the game does not deal with it correctly.
Few things work fine - e.g. Laboratory and Enhancement chamber. When you recall the dice, the countdown continues, but the building action will be cancelled. (without returning price paid for operation)

However:
- recall from resource gathering will still get you the resources and adequately lower the resource-point durability.
- recall from production building such as Wheat farm, Mill and Brewery will still get you the result. This way, it is e.g. possible to operate 6 fields with a single dice almost at the same time.
- recall from buildings that creates dice (e.g. Almshouse, Military Academy, ...) will still grant you a new dice after countdown. Free dice for everyone I guess ;)

---

Bug #2:

Dices can have traits.
Traits like "Highlander", "Meek", "Tough", ... .

There is a one special type of dice - mercenary dice. This dice always have "mercenary" trait, which states:
"cannot be fed" & "will perish if wounded".
By using Laboratory, I was able to get a construct dice (from 6 sacrificed mercenary dice) which did NOT have the "mercenary" trait, but it still behaved like it _do_ have the trait.

---

Bug #3:

I ascended a dice.
After that I threw that dice into a forge, destroying it and making a whole different construct dice.
The original dice was still marked as ascended though. And I got it exported after I won the game.

On the other hand, when you start a game with ascended dice AND loose it, you will loose the ascended dice too, forever.

While this might not be a bug, it sure feels like one of the behaviours might not be intended.

---

Bug #4:

There is an area of "glass wall" - when you try to click on the game elements that are too near of a top or bottom border, you can see those game elements; it feels like you could interact with them, but you can NOT.
The click just won't proceed.

It would be nice to either allow such clicks or give the player some form of feedback that that is not an area of the screen the player can interact with.

---

Feature Request #1:

The game have tutorial, some sort of help and other means how to offer explanation for a player.

On the other hand there is a number of things that is NOT documented anywhere AND is just frustrating.
E.g.:
- When you start a game with ascended dice AND loose it, you will loose the ascended dice too, forever.
I can't imagine a single sane reason why a player should not be warned about it, even more when he spent hours and hours getting those two ascended dice.

There is a lot of simple information which I personally believe have no value in being classified, yet they are.
The one I described was the very peak of Mount Frustration; other would be just nice to have confirmed. (e.g. construct dice behaves as a dice of all the classes it consists of; which affect e.g. offered policies. and need to maintain class happiness. No big deal in late game; crucial when using such ascended construct multi-class dice at the start of a new game)

---

Feature Request #2:

When you hover cursor over a dice in your pool, you can see it's details; all faces (sides), traits ... .
It would be a nice (maybe optional?) feature to be able to see such details when hovering over a dice that is assigned to a location too.