It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Yo, last month I got the itch to play D1 again, but it didnt boot, so I got the GOG version and that worked fine, but the newly released hellfire expansion does the same thing that my retail D1 CD used to do, it boots to a black screen, crashes to desktop and makes an .ERR file in its root directory.

Any clues on how to fix?

Also, while im at it, anybody knows how to make it so that the launcher doesnt do gamma correction? i use a blue light filter and D1 on GOG ignores it.
This question / problem has been solved by jjstraka34image
Same here but no error message, just crash.
Post edited June 05, 2019 by IntrepidTalent
avatar
IntrepidTalent: Same here but no error message, just crash.
i dont get any error message, i get an error file in the install directory.

this seems to only happen in my new hard drive, my old one was dying but D1 worked, the GOG version works and so do belzebub and the hell 2 though
avatar
brunocar: Yo, last month I got the itch to play D1 again, but it didnt boot, so I got the GOG version and that worked fine, but the newly released hellfire expansion does the same thing that my retail D1 CD used to do, it boots to a black screen, crashes to desktop and makes an .ERR file in its root directory.
I seem to be having this problem as well, any chance of a fix?
I have the same problem, game crash to desktop right after i start the Hellfire.
You need to totally disable DEP for everything except Windows functions. Adding Hellfire as an exception did not work for me, but this did.
avatar
jjstraka34: You need to totally disable DEP for everything except Windows functions. Adding Hellfire as an exception did not work for me, but this did.
right but also wrong, you dont need to fully disable DEP, i just tried setting it to be enabled only for windows processes and then rebooted, D1 and mods now run without a hitch, including hellfire.

that said, how do i disable the gamma correction in the GOG wrapper? its making my game look way too blue
avatar
brunocar: right but also wrong, you dont need to fully disable DEP, i just tried setting it to be enabled only for windows processes and then rebooted, D1 and mods now run without a hitch, including hellfire.
Yeah, I just got that to work as well!
What’s is DEP?
avatar
Fiendish18: What’s is DEP?
A Google search for "windows dep" suggests this is "Data Execution Prevention." Interestingly, most of the hits on the first page deal with disabling it.