It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Dex 2.1.0.2 crashes at start on an up-to-date 32-bit Debian 8.6 (jessie) system. All required libraries from the game card are installed with 2 exceptions:
- libasound2-data:all is installed instead of libasound2-data:i386 (data packages do not depend on the system architecture on Debian)
- libglu1-mesa:i386 is installed instead of libglu1:i386 as there is no libglu1:i386 available on Debian

The log does not give much hints:

displaymanager : xrandr version warning. 1.4
client has 2 screens
displaymanager screen (0)(DVI-I-3): 1600 x 1200
Using libudev for joystick management
Importing game controller configs
support/gog_com.shlib: line 94: 18319 Aborted ./"${bin_32}"
When I trace the binary I see some (failed) access to Pulse files like /var/run/pulse/native and after that a SIGSEGV. Not sure if that helps anything or is even relevant:

connect(21, {sa_family=AF_LOCAL, sun_path="/var/run/pulse/native"}, 110) = -1 ENOENT (No such file or directory)
close(21) = 0
rt_sigaction(SIGCHLD, NULL, {SIG_DFL, [], 0}, 8) = 0
clone(child_stack=0, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD, child_tidptr=0xb4b97768) = 20753
waitpid(20753, [{WIFEXITED(s) && WEXITSTATUS(s) == 1}], 0) = 20753
--- SIGCHLD {si_signo=SIGCHLD, si_code=CLD_EXITED, si_pid=20753, si_uid=1000, si_status=1, si_utime=0, si_stime=0} ---
munmap(0xa3f8a000, 67112960) = 0
unlink("/dev/shm/pulse-shm-3392773607") = 0
close(19) = 0
close(20) = 0
write(6, "FMOD failed to get number of dri"..., 128) = 128
--- SIGSEGV {si_signo=SIGSEGV, si_code=SEGV_MAPERR, si_addr=0x344} ---
Does Dex require Pulse? Any other ideas?

Am I supposed to install the patch? I should not as the patch has a lower version number (2.0.1.2) than the game installer (2.1.0.2). But you never know as the two version numbers rather look like a typical GOG glitch. ;)

Unfortunately not even the Windows version works under Wine although the retail version is rated platinum on winehq. The game at least starts (with Wine 1.9.21) and seems to run, but I only get a black screen.
Post edited November 07, 2016 by eiii
No posts in this topic were marked as the solution yet. If you can help, add your reply
Thanks to this thread I found a solution at least for the Linux version. So it's indeed a problem how the game tries to access Pulse audio and the workaround is to fool the engine by giving it an empty library:

ln -s /dev/null libpulse-simple.so.0
Post edited November 07, 2016 by eiii
Dex 2.3.0.4 (5.4.0.0) crashes at start on 64-bit Debian (unstable)

stderr contains many "Searching for joysticks..."

I solved it by install package "libudev1:i386".