It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I've installed the game and after the initial setup the game seemed to be running perfectly fine. That is, until I've reached the water part of the training. At this point the framerate dropped significantly, making the game almost unplayable. I have a Radeon HD6300 / Intel Hd 3000 (switchable) graphics card. However, the game chose the latter during the configuration and I was unable to change it in any way. Did anyone encounter a similar issue?

On a side note: I've played a non-gog version of Deus Ex before I switched from Win7 to Win10 and it seemed to be running perfectly fine. Also, I've tried Kentie's launcher but it doesn't seemed to work on Win10 - after trying to execute it nothing happens.
This question / problem has been solved by eviltypeguyimage
avatar
flv2358: I've installed the game and after the initial setup the game seemed to be running perfectly fine. That is, until I've reached the water part of the training. At this point the framerate dropped significantly, making the game almost unplayable. I have a Radeon HD6300 / Intel Hd 3000 (switchable) graphics card. However, the game chose the latter during the configuration and I was unable to change it in any way. Did anyone encounter a similar issue?

On a side note: I've played a non-gog version of Deus Ex before I switched from Win7 to Win10 and it seemed to be running perfectly fine. Also, I've tried Kentie's launcher but it doesn't seemed to work on Win10 - after trying to execute it nothing happens.
Probably your issue is only related to the chaos of the dual video cards instead of the current windows, as Gog version officially do not support the Intel's cards.
I had similar issues with a modern game of a indie game and was forced to shutdown my intel's card 100% for be able to play it. Deus was developed more than one decade before said concept was created.
I've tried shutting down the card but it resulted in the game choosing software rendering only :| Thanks for the reply though!
avatar
flv2358: I've tried shutting down the card but it resulted in the game choosing software rendering only :| Thanks for the reply though!
Welcome to our hell then, for some machines is hard to make the game to run (you will find my rants in this sub-forum :P ). Yet, probably in your case will be sane if you try all the alternatives in this forum using only the ATI card.
I've found a partial solution, or at least it has helped to deal with those performance issues and minor graphic glitches with my card. Simply switch the color depth from 16 to 32-bit and restart the game. In my case, it runs much smoother.
avatar
flv2358: I've installed the game and after the initial setup the game seemed to be running perfectly fine. That is, until I've reached the water part of the training. At this point the framerate dropped significantly, making the game almost unplayable. I have a Radeon HD6300 / Intel Hd 3000 (switchable) graphics card. However, the game chose the latter during the configuration and I was unable to change it in any way. Did anyone encounter a similar issue?

On a side note: I've played a non-gog version of Deus Ex before I switched from Win7 to Win10 and it seemed to be running perfectly fine. Also, I've tried Kentie's launcher but it doesn't seemed to work on Win10 - after trying to execute it nothing happens.
avatar
Belsirk: Probably your issue is only related to the chaos of the dual video cards instead of the current windows, as Gog version officially do not support the Intel's cards.
I had similar issues with a modern game of a indie game and was forced to shutdown my intel's card 100% for be able to play it. Deus was developed more than one decade before said concept was created.
Actually, I've hit this same issue on Windows 10 and I only have a single NVidia GTX 580. Setting the texture color depth to 32-bit seems to resolve the issue. GoG should consider making that the default.
Post edited August 30, 2015 by eviltypeguy
avatar
flv2358: I've found a partial solution, or at least it has helped to deal with those performance issues and minor graphic glitches with my card. Simply switch the color depth from 16 to 32-bit and restart the game. In my case, it runs much smoother.
Yes! it worked, was driving me mad.