It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hi everyone,

I just got Deus Ex in the sale, but strangely the game just looks very dark on my computer (vanilla gog version, without any mods).

The HUD and menu elements look fine, but for some reason I can hardly see the game itself. I've attached a screenshots of the starting area, I think some textures in the game are just not being drawn or something. I definitely remember the wooden dock being a lot brighter than what I'm seeing.

Any help would be great. Thanks in advance!

EDIT: For some reason, I cannot upload screenshots. Here's a link to 2 images:
http://i.imgur.com/mSQjz.jpg
http://i.imgur.com/uiBM6.jpg
Post edited September 28, 2012 by arvindrajayadav
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
arvindrajayadav: [snip]
Your best bet is to turn up the game's brightness, from the Display Settings submenu of the Settings menu.
avatar
arvindrajayadav: [snip]
avatar
boct1584: Your best bet is to turn up the game's brightness, from the Display Settings submenu of the Settings menu.
These screenshots were taken at the maximum brightness. And the lighting on the HUD is okay, but somehow it's completely dark in the levels alone.
I fixed it. Changing the renderer from Direct3D to OpenGL fixed the problem. Turns out the darkness was just several textures not being drawn at all.

EDIT: Welp, I cannot mark my own post as solved. But the problem is solved, atleast for now.
Post edited September 29, 2012 by arvindrajayadav
avatar
boct1584: Your best bet is to turn up the game's brightness, from the Display Settings submenu of the Settings menu.
avatar
arvindrajayadav: These screenshots were taken at the maximum brightness. And the lighting on the HUD is okay, but somehow it's completely dark in the levels alone.
Try using a different rendering engine, see if that does anything. There are links in the sticky.
avatar
arvindrajayadav: I fixed it. Changing the renderer from Direct3D to OpenGL fixed the problem. Turns out the darkness was just several textures not being drawn at all.

EDIT: Welp, I cannot mark my own post as solved. But the problem is solved, atleast for now.
awesome cheers for the update, I had the same problem fixed it straight away, champion
avatar
arvindrajayadav: I fixed it. Changing the renderer from Direct3D to OpenGL fixed the problem. Turns out the darkness was just several textures not being drawn at all.

EDIT: Welp, I cannot mark my own post as solved. But the problem is solved, atleast for now.
How did you render it in Open GL?
avatar
arvindrajayadav: I fixed it. Changing the renderer from Direct3D to OpenGL fixed the problem. Turns out the darkness was just several textures not being drawn at all.

EDIT: Welp, I cannot mark my own post as solved. But the problem is solved, atleast for now.
avatar
SimonZephyr: How did you render it in Open GL?
In the game menu, on the "Display Settings" section, you get an option to change the "Rendering Device". Do it. And next time you start the game you get the chance to change your display option. Instead of choosing Direct 3D go to the other alternatives.