It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hey all. I am having an issue playing Invisible War. Whenever I try to start a new game or load a previous saved game, the screen will go black and nothing happens. I cannot alt-tab, and control-alt-delete will not allow me out of the game so I am forced to do a hard shutdown.

I installed the Visible Upgrade, and that worked once, but now I am back in the same boat. Anyone have any suggestions? Below are my specs:

2560x1440
i7-9700k
RTX 2080
This question / problem has been solved by TopFloorimage
avatar
tgs_bg: Hey all. I am having an issue playing Invisible War. Whenever I try to start a new game or load a previous saved game, the screen will go black and nothing happens. I cannot alt-tab, and control-alt-delete will not allow me out of the game so I am forced to do a hard shutdown.

I installed the Visible Upgrade, and that worked once, but now I am back in the same boat. Anyone have any suggestions? Below are my specs:

2560x1440
i7-9700k
RTX 2080
Perhaps you have already tried, but you might want to try running it in compatibility mode. I remember playing it flawlessly on Win 7 ages ago.
avatar
tgs_bg: Hey all. I am having an issue playing Invisible War. Whenever I try to start a new game or load a previous saved game, the screen will go black and nothing happens. I cannot alt-tab, and control-alt-delete will not allow me out of the game so I am forced to do a hard shutdown.

I installed the Visible Upgrade, and that worked once, but now I am back in the same boat. Anyone have any suggestions? Below are my specs:

2560x1440
i7-9700k
RTX 2080
avatar
Pkmns: Perhaps you have already tried, but you might want to try running it in compatibility mode. I remember playing it flawlessly on Win 7 ages ago.
Tried that, unfortunately that doesn't do anything different.
avatar
tgs_bg: Anyone have any suggestions?
According to this post, another software might be conflicting with the game.

Launch the game and, before doing anything else, open the Task Manager. Browse to the "Details" tab and look for the game executable (dx2main.exe): right click on it and select "Analyze waiting chain".
The debugging tool should show the processes which are conflicting with the game (more information here): close them and return to the game, which should work fine now.
Is it possible you have any kind of overlay active. I had the exact same problem and it looks like it clears up when I turn off the GeForce Experience overlay. ...so it's great that I can track down the problem, but kind of unfortunate for me since I wanted to capture some 4K screenshots of the game using GeForce Experience...but I have to turn off the screenshot feature in order to load into the game. :/

Anybody know any good (and free) software I can use to capture screen shots with that won't stop this game from loading?
avatar
TopFloor: Is it possible you have any kind of overlay active. I had the exact same problem and it looks like it clears up when I turn off the GeForce Experience overlay. ...so it's great that I can track down the problem, but kind of unfortunate for me since I wanted to capture some 4K screenshots of the game using GeForce Experience...but I have to turn off the screenshot feature in order to load into the game. :/

Anybody know any good (and free) software I can use to capture screen shots with that won't stop this game from loading?
It was the GeForce Experience overlay! As soon as I disabled it, it works perfect now! Thanks a lot!!!
avatar
tgs_bg: Anyone have any suggestions?
avatar
dr.schliemann: According to this post, another software might be conflicting with the game.

Launch the game and, before doing anything else, open the Task Manager. Browse to the "Details" tab and look for the game executable (dx2main.exe): right click on it and select "Analyze waiting chain".
The debugging tool should show the processes which are conflicting with the game (more information here): close them and return to the game, which should work fine now.
TopFloor gave me the solution, but this sounds good to try for any other games I have in the future that give me problems. Thanks!
Post edited March 07, 2021 by tgs_bg