It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I have Windows 7 Premium x64, the game loads and plays; but only in a window. After a few days of searching I have yet to find a solution to make it full screen, or even increase the size of the window past the highest in game resolution (on a 24" monitor at 1920x1080 IMO it's still tiny). Is it even possible to run the game full screen on Win 7?

I have tried altering the "user.ini" file located in the documents folder (oddly no resolutions listed for full screen, just windowed). I have tried "Dues Ex Widescreen Utility" to alter "engine.d2u". I have tried "Alt+Enter". I have tried adding commands to the target on the shortcut. None of which have worked. On a side note when I try launching "DX2main.exe" and "Ion Launcher.exe" I get a warning telling me to "please run dx2, not dx2main/ion launcher".

Windows 7 Premium x64
8gigs ram
AMD Athlon II 630 Quad core
Radeon HD 6950 2gig
Install location "C:\gog games\Deus Ex - Invisible War" compatibility Win XP sp2 with admin privileges

I have read on other forums that people run this game fine/perfectly on Win 7, though they do not mention what "fine" is: or what they have altered or their specs. I have also read posts of people asking to make it windowed so it will not crash in Win 7.
This question / problem has been solved by dj.501image
avatar
Stray_Ion: I have tried altering the "user.ini" file located in the documents folder
Does it mean that you added "StartupFullscreen=True" in [WinDrv.WindowsClient] section and it doesn't work?

You mentioned no resolution for Fullscreen, try adding this in the same section:
FullscreenViewportY=1920
FullscreenViewportX=1080

You can also try this utility - http://forums.anandtech.com/showthread.php?t=2088245

edit: check also default.ini in the DXIW installation folder
Post edited November 22, 2014 by triock
I have already tried that utility, but I forgot about the default.ini. Thanks for mentioning that.

I added "StartupFullscreen=True" as well as "FullscreenViewportY=1920" and "FullscreenViewportX=1080" to the user.ini file, but it didn't work. I also changed the windowed and full screen resolutions in the default.ini, fullscreen was already set as True. Also "Alt+enter" with those changes still does not work.
avatar
Stray_Ion: ... I added "StartupFullscreen=True" as well as "FullscreenViewportY=1920" and "FullscreenViewportX=1080" to the user.ini file, but it didn't work. ...
Maybe you're editing the wrong User.ini. Check if there's one in the game's folder.
Also mind, that if you're running the game with another user (e.g. a separate admin account), the correct User.ini might be in its Documents folder.
Post edited November 24, 2014 by DeMignon
Unfortunately I know I have the right user account, its the only one. I checked the game directory and couldn't find another user.ini. I feel I'm overlooking something simple, I still hope that's the case.

I'm almost to the point where I'm going to try my on board gpu, or an old nvidia card I have laying around to see if its a hardware issue.
avatar
Stray_Ion: ... I'm almost to the point where I'm going to try my on board gpu, or an old nvidia card I have laying around to see if its a hardware issue.
Are you sure the game isn't already using the onboard GPU. Embedded chips and their drivers often cause troubles with games. Make sure the game uses the Radeon, e.g. by setting the game to High Performance in the Catalyst Control Center if the GPUs are switchable on your system.
Explicitly using the integrated chip is still worth a try, it could surprisingly work if there's an driver issue or whatnot with the Radeon.
Yes, I'm sure I'm not currently using my on board gpu. I also forgot to mention that I also have 2 monitors in my original post (both through the HD6950).

Unfortunately I won't be able to mess around with gpu's for a couple more days when I have the time.

An additional note, I did a fresh install a few months ago after a hard drive failure (for once Win7 disk failure warning was correct, my old drive actually had too many bad sectors to be stable). All my drivers are new.
I just installed DX:IW in my machine, which is also Win 7 64-bit Premium with 8GB. I was very sad to see it hang right after the intro cutscene. I tried to set compatibility mode to XP SP3, but that didn't work either.

Is there a fix for this? I just finished the first game, and would like to continue the story line.
Post edited December 01, 2014 by Kitsudragon
I had a (brief) odd message appear. Something about "Viktoria" which I think might be an in-game error tracking routine. Sadly, it was gone before I could see what it said. But the game clearly had some kind of error while trying to load the first map. Still don't know what it was.
avatar
Stray_Ion: I have Windows 7 Premium x64, the game loads and plays; but only in a window. After a few days of searching I have yet to find a solution to make it full screen, or even increase the size of the window past the highest in game resolution (on a 24" monitor at 1920x1080 IMO it's still tiny). Is it even possible to run the game full screen on Win 7?

I have tried altering the "user.ini" file located in the documents folder (oddly no resolutions listed for full screen, just windowed). I have tried "Dues Ex Widescreen Utility" to alter "engine.d2u". I have tried "Alt+Enter". I have tried adding commands to the target on the shortcut. None of which have worked. On a side note when I try launching "DX2main.exe" and "Ion Launcher.exe" I get a warning telling me to "please run dx2, not dx2main/ion launcher".

Windows 7 Premium x64
8gigs ram
AMD Athlon II 630 Quad core
Radeon HD 6950 2gig
Install location "C:\gog games\Deus Ex - Invisible War" compatibility Win XP sp2 with admin privileges

I have read on other forums that people run this game fine/perfectly on Win 7, though they do not mention what "fine" is: or what they have altered or their specs. I have also read posts of people asking to make it windowed so it will not crash in Win 7.
I have the same problem, game run always in windowed mode and I'm unable to change it to fullscreen...
But by laboring/testing with all settings in file "user.ini" I solved this, at last!

In my config, if in variable MultiSampling is any value higher than 1, game runs in Windowed mode. If I set MultiSampling=1, game run in fullscreen.

Solution:
edit "user.ini" in your savegames folder (...\Documents\Deus Ex - Invisible War\) and set:

MultiSampling=1
avatar
Stray_Ion: I have Windows 7 Premium x64, the game loads and plays; but only in a window. After a few days of searching I have yet to find a solution to make it full screen, or even increase the size of the window past the highest in game resolution (on a 24" monitor at 1920x1080 IMO it's still tiny). Is it even possible to run the game full screen on Win 7?

I have tried altering the "user.ini" file located in the documents folder (oddly no resolutions listed for full screen, just windowed). I have tried "Dues Ex Widescreen Utility" to alter "engine.d2u". I have tried "Alt+Enter". I have tried adding commands to the target on the shortcut. None of which have worked. On a side note when I try launching "DX2main.exe" and "Ion Launcher.exe" I get a warning telling me to "please run dx2, not dx2main/ion launcher".

Windows 7 Premium x64
8gigs ram
AMD Athlon II 630 Quad core
Radeon HD 6950 2gig
Install location "C:\gog games\Deus Ex - Invisible War" compatibility Win XP sp2 with admin privileges

I have read on other forums that people run this game fine/perfectly on Win 7, though they do not mention what "fine" is: or what they have altered or their specs. I have also read posts of people asking to make it windowed so it will not crash in Win 7.
avatar
dj.501: I have the same problem, game run always in windowed mode and I'm unable to change it to fullscreen...
But by laboring/testing with all settings in file "user.ini" I solved this, at last!

In my config, if in variable MultiSampling is any value higher than 1, game runs in Windowed mode. If I set MultiSampling=1, game run in fullscreen.

Solution:
edit "user.ini" in your savegames folder (...\Documents\Deus Ex - Invisible War\) and set:

MultiSampling=1
I no longer have Win7, but I just installed this in Win10 (same computer, with same specs as before) and by default MultiSampling was set to 1. I increased it to 8 within the in game options and restarted it, and it was still full screen. I no longer have access to a pc running Win7 unfortunately to see if this would have fixed my previous issue.

I will however mark your post as a solution for those who run into this problem in the future. Thank you for all your effort.