It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hello, people. I just started Deus Ex and have an issue with lights (screenshots attached). When I use the light in dark areas, only the background or the objetcs in front of me are enlightened. The light doesn't flows naturally when I move it, it seems to jump from different parts of the walls/objects.

Anyone know if the engine is supposed to work like this, or is really a glitch? I'm using several mods (DeusEx_MapsPatch10, New_Vision_v1-5, HDTP-Release3, unifiedDeusEx_v0.2.1, installed in this order), so maybe one of them is causing the issue. I'm using DirectX10 renderer from kentie that comes with New Vision.

I'm on Win 7 64 bit and my GPU is a NVIDIA 520M that usually runs without problems old "remastered" games.

* screenshot in low resolution to fit the file size limit of the forum, sure I'm not playing the game like Doom...

Just to clarifym I have already found these topics, that probably relate to the same problem, but the solutions provided in them did not work for me (including the change to OpenGL). So if anyone has another suggestion...

https://www.gog.com/forum/deus_ex_series/black_textures_in_deus_ex_goty

https://www.gog.com/forum/deus_ex_series/unlit_textures_when_using_kenties_directx_10_mod
Attachments:
deusex.jpg (78 Kb)
Post edited July 02, 2016 by rosumek
This question / problem has been solved by Whelpimage
you answered your own questions. Used mods and broke it, cause of problem discovered hehe.
avatar
eolsunder: you answered your own questions. Used mods and broke it, cause of problem discovered hehe.
Nope. The mods created some glitches (but totally worth it), but this is not one of them. After playing the game and watching some videos in youtube, I've found that is the "normal". In one video the own developers joke about this strange lightning in the game... But that's ok, the worst part is only that one in the tutorial. It's not an issue in the game itself.
I'm pretty sure that's just how dynamic lighting works in the old unreal 1 engine.
The DX10 renderer is known to cause issues, particularly with flickering black areas on reflective surfaces. I'd try using the OpenGL drivers that came with New Vision personally.
Post edited October 12, 2016 by losthorizon
avatar
Whelp: I'm pretty sure that's just how dynamic lighting works in the old unreal 1 engine.
Right, is how the game is supposed to be. But fortunately is not so bad during the game.

I even saw a YouTube video where there of the game creators played it again and their made fun of this issue. :p