It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I downloaded Deus Ex GOTY edition off GOG and it was too dark. I googled the issue and people said that Kentie's Deus Ex mod could fix the problem. I put the contents of the zip file into the Deus Ex system folder and replaced the deus ex file it told me to, but when I try to start the game, it crashes on launch. I am running windows 10 through bootcamp, so maybe that has something to do with it? Can someone help me?
Post edited October 07, 2016 by Bomber567
No posts in this topic were marked as the solution yet. If you can help, add your reply
I have no idea about Bootcamp, though having a quick look it seems to boot you into a Windows install so that shouldn't be the problem, especially if Windows and other games work.


You only mention "Kentie's Deus Ex mod" which could be considered vague.


If you haven't I'd suggest trying both of the following together.

http://kentie.net/article/dxguide/index.htm
http://kentie.net/article/d3d10drv/index.htm

With both installed Deus Exe (deusex.exe) should present you with a launcher when started. From there you can click Configure and select Direct3D 10 as a rendering option (maybe try others if that gives you problems), you can also select other relevant options for your system and personal preference.

Click OK, then click Play.
A bit late, but this may help others.

I ran into the same issue and resolved it in the same manner that Bomber567 did. I was able to play around with the settings and get it to startup, but there were some pretty egregious problems like not being able to switch weapons once you chose your first weapon.

In the end what resolved the issue for me was to reset all the files back to factory defaults and then when it asks you to select a device, click the "show all hidden devices" button and choose the 3dfx option.

If you find yourself having problems with the resolution make sure you set it to 32-bit color and then restart. If you're still having trouble with the resolution crack open the system/DeusEx.ini file and update the following properties.

FullscreenViewportX=1600
FullscreenViewportY=1200
Post edited November 18, 2016 by mreiland