It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I'm trying to run DE:IW on my laptop (Win 7) and cannot even start it. I tried different compatibility modes but it didn't help - it always crashes at the very beginning (before any loading screen) Do have any idea how to fix it?
No posts in this topic were marked as the solution yet. If you can help, add your reply
Ok, I've solved the problem myself. I've changed the compatibility mode but not for DE2.exe file but DE2main.exe instead (Win 98) and it works fine.
This is a bit older post, but not too old and I ran across it after encountering a similar issue myself.

My computer is Win 7 x64, and switchable video (Nvidia and Intel). Games run on Nvidia of course.

What I was running into is that DE:IW would start up, I could configure options, and watch the opening cutscreen after starting a new game. I could then select my character portrait and UI color, but after clicking "Start" it would just go to a black screen. If I got tired of waiting, Task Manager showed it as Not Responding.

One time, there was also a "Viktoria Error" in Task Manager. But it seems like you can recover it by doing this:
-When it goes to a black screen, ctrl-alt-del and choose Task Manager fairly soon (the Viktoria error happens if you wait a while at the black screen).
-close the Ion Launcher process
-then close the DE:IW process
-then reset your desktop back to optimal resolution (so far just waiting hasn't worked, but I have to reset the resolution? Maybe I just haven't been patient enough :) )

So far this has been working as a workaround for me, but I haven't been messing with it too long. Maybe there is a cleaner way to get this running without the black screen.
Ok, so an update.

When I made my earlier post, I had only encountered the "black screen on loading" bug for the first time and had only messed with it for a bit. I thought because the game played OK afterwards, that it was a one-time thing to start the game. Once I had an actual game started, I'd be good.

Nope.

The black screen problem occurs any time the game loads. Loading between levels, loading a save game, etc. So the black screen was unacceptable for playing--I couldn't wait 5-10 minutes for each load.

I did some search and found this is a common problem. The Steam Forums in particular have a lot of posts about this bug. The takeaways were: the cause of this problem varies from system to system, and the only possible common factor may be some software interacting with the graphics card in some way.

I tried some of the common suggestons: closing my browsers, closing Steam, shutting off antivirus, running the EXEs associated with this program with different compatibility modes and with the "disable visual themes" and "disable desktop composition" options, getting rid of the Aero interface and going with Classic etc. My laptop does use Realtek audio, but I do not have an external sound device I can swap to (and IW wil not run if you disable your sound card).

After nothing was working, I got frustrated, opened up Task Manager, chose to display processes from others and started mass "end task"ing all non-MS processes that I could (I'd already shut down everything, and figured worst case I'd reboot my laptop).

Somewhere in the list was whatever was locking it. I've been able to load just fine now. I don't know what it was because I wasn't going to take the time to write down every process and test them. There was one for THXAudio that is associated with Realtek, but also some camera ones, a quickbar and some other stuff.

Anyway--the black screen problem differs for everyone, but it is potentially fixable for many.

/edit: Oops, forgot to add that I've even gone back in and turned some stuff on: reenabled Aero, opened Steam, opened a browser, now turned on my keyboard backlight and so far IW keeps working. I've not rebooted and reenabled all processes again--I am sure IW would break until I ended the magic process or processes again.
Post edited February 07, 2013 by notepad
Thanks for the info notepad. Because of it I am finally able to play DE:IW on my own computer.

Oh, just in case more people have this problem, on my computer it was the setpoint.exe process from Logitech that caused the crash. as soon as I closed that process the game loaded up just fine.
Along the same lines, I've found that I often can't run the game on my system if Google Chrome is running, so you might try closing it if you're having similar problems.