It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I get 1 FPS in animations. Like when the train arrives first few seconds in the game. And in menus during animations in game.

Have tried everything I can possible do:

*third party products shut off
*directx installation
*The newest drivers for my computer (Asrock 156b, 1 month old). Nvidia won't install drivers.

There is slightly better FPS in 640x480 resolution. Maybe 4 - 6 FPS in animations.

Some people with the same problem (google) had to use an emulator and run the game from there. But I'm not that Desperados I guess :)
I have the same problem. Since there have been no replies to this post, I guess we're in the minority.
Yep, I'm experiencing the same with my install. Seems to work slightly better at lowest resolution, but still it's chopping too much for a smooth and enjoyable gameplay.
I set my screen to 16bit and resolution to 1024x768 before starting the game. Now animations run in 5-8 FPS and the rest in 12-15 FPS.

I've also tried Ctrl+Alt+Delete and turn the game to use 1 core. Which gives me 50FPS animations for 10 seconds! Then it turns back to 3FPS animations.

But it's to much problem with this game. Shame on GOG.

Bought the game several months ago and havn't played it yet for the same reason.

I'm running the game under Win 7 64-bit and I tried all the above methods without much succes. I also played with the "Compatibility" settings but it didn't work neither.

Has someone found a solution in the meantime?
Experiencing the same issue.

So i guess this is a fairly universal problem :/
I played the first 5 levels on my old desktop machine (winxp, intel dual core, nvidia 8800gts) and it ran incredibly smooth.

Just bought a new laptop (asus g53sw, win7x64), installed the game and it is unplayable as described by others in this post.

If anybody finds a solution please share.
Same problem here. :(

Win 7 x64, dual core, nvidia 9600m gt
I've read that there is a config utility (dxcpl.exe) included in the Directx SDK that allows you to disable directx acceleration. I can remember disabling acceleration for certain games on WinXP to clean up graphical glitches but unfortunately with Win7 and nvidia drivers this is no longer built in so the utility is required.

I can't try it right now but I'll post an update if this works.

BTW, here is my laptop config:

Intel Core i7 2630QM, HM65 Express chipset
Win 7 Home Premium 64 bit
Follow up on my last post.

I installed the DirectX SDK and ran the DirectX control panel. Under the 'DirectDraw' tab, I unchecked the 'Use Hardware Acceleration' checkbox and launched the game.

The slowdown was gone in the menus and during gameplay, BUT the surface animations left trails and the background wasn't being drawn.

I tried messing with a bunch of different options on the control panel and in game but I couldn't fix the graphical issues.

I give up... for now
Here is something you can try that I found works with playing many older games on modern operating systems particularly Windows 7. However it requires that you have a dual graphics cards installed. In my case I have both a Intel Integrated 4000 graphics card along with a GeForce GTX 675M. I set an exclusion in the nVidia properties page to run this game exclusively under the Intel Integrated 4000 card which does not have many of D3D / OpenGL features, and basically uses windows only technology. Glitches are gone, framerates are stable at >30 fps and game runs like a charm. Mouse trails can still be a problem on some games (JA2 comes to mind), which can be eliminated in windows mode, which is this game I have not tested.