It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I bought the Steam release of Deathtrap Dungeon, and I keep trying to run it, but it keeps crashing after the opening cinematics.

I've looked online and tried the replacement DLLs fix, but it didn't work. I've messed around with compatibility modes, but it keeps crashing after the intro cinematics.

I just bought the GOG release after trying to fix the Steam version, but the same issue occurs.

Does anyone know what else might be causing an issue? I think it might be a setting to do with config or NGlide, but I don't know what the issue might be.

EDIT: Something I just remembered. As the game was downloading, a cmd.exe window popped up during configuration, but it never closed. I eventually just closed it. I figured it maybe didn't install something correctly, so I uninstalled the game, and redownloaded it after running GOG Galaxy as Administrator. Still, it crashes.

EDIT2: Everytime I start the game, I get a window with title "DirectX Error" and the message 'Acquire (mouse) failed'. Could DirectX be causing an issue? I just recently upgraded to Windows 10 from Windows 7, and I reinstalled DirectX since I was told it was not included. I downloaded the DirectX End-User Runtimes here[www.microsoft.com], but do I need to download something else additionally?
Post edited January 02, 2020 by MaxWilco
Well, I fixed it, but I have no clue what I did in order to do it.

I decided to restart my computer and when I tried running the game again, I didn't get an error about DirectX and the mouse, and the game worked! Tried downloading the Steam version again, ran it, and it worked as well!

I'm glad I got the game running, but I don't know what I did to actually fix it. I'm guessing the restart made it so that it had to check for something that was installed or changed, and found it, but I don't know what.

I did try reinstalling the DirectX Runtimes again before restarting my computer, so maybe that had something to do with it? When I redownloaded the Steam version, the replacement DLLs were still there, so I don't know if it was from when I tried adding them earlier, or if it was from running the game.

Does anyone know what the issue might have been?