It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I don't know why I keep trying. It only ever leads to more rage.

I tried starting this game up today, I start up the launcher, go to settings, then the language select bar selects itself, AND THERE'S NO WAY TO ACCESS ANYTHING ELSE. No way to exit the screen either, way...I have to spam the ESC key over, and over, again until it eventually closes the launcher.


How incompetent can a developer be? Was their coder a literal chimp? Were the devs taking turns hurling peanuts and hard candy at it why it tried to work in between hitting each other with clawhammers and butt-chugging cough syrup?

Just another reason I will never buy anything with Rising Star's name on it. My bad history with this port and this company go back. When I originally complained about this game being unplayable to them YEARS AGO; I got an apology and an offer of a free copy of any of their other available games. The one I chose ALSO DIDN'T WORK. I came back and complained about the new broken game they had given me, and got politely told me to piss off.

I do not speak in hyperbole when I say: This is the single worst port of any game ever made. Rising Star Games are incompent at best, and shady at worst. Stay away from this port. Stay away from the people behind it.