It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Is it just me or is the game not launching in Galaxy?
(i'm on macOS 11.1 on an M1 mac).
avatar
PSi_AU: Is it just me or is the game not launching in Galaxy?
(i'm on macOS 11.1 on an M1 mac).
Hi i am on mac mini 2019 , managed to fix issue.
Something wrong "ssl" library and other dependencies for it "libmbed*" and so on .
What i did backup the current version what is broken . and install previous version 1.11.1

and from previous version copy files to. new 1.12.1 version

you can do business through "muCommander"

This content of my folder , what is JAN 5 "libraries from the previous" , and do not forget about your "save" folder.

Vasiliys-Mac-mini:Dead Cells bazilxp$ pwd
/Applications/Dead Cells
Vasiliys-Mac-mini:Dead Cells bazilxp$ ls -la
total 1920688
drwxr-xr-x 30 bazilxp admin 960 Jan 27 22:12 .
drwxrwxr-x+ 99 root admin 3168 Jan 27 22:14 ..
drwxr-xr-x 3 bazilxp admin 96 Jan 27 21:57 Contents
-rw-r--r-- 1 bazilxp admin 71977 Jan 27 21:58 ThirdPartyLicenses.txt
-rwxr-xr-x 1 bazilxp admin 60 Jan 27 21:57 deadcells
-rwxrwxrwx 1 bazilxp admin 97584 Jan 27 21:58 fmt.hdll
-rwxrwxrwx 1 bazilxp admin 34596 Jan 27 21:58 gog.hdll
-rwxr-xr-x 1 bazilxp admin 178320 Jan 5 18:41 hl
-rw-r--r-- 1 bazilxp admin 15828671 Jan 27 22:00 hlboot.dat
-rwxr-xr-x 1 bazilxp admin 33971404 Jan 5 18:41 libGalaxy.dylib
-rw-rw-rw- 1 bazilxp admin 1210440 Jan 27 21:57 libSDL2-2.0.0.dylib
-rw-r--r-- 1 bazilxp admin 436844 Jan 5 18:41 libhl.dylib
-rw-r--r-- 1 bazilxp admin 870664 Jan 5 18:41 libmbedcrypto.0.dylib
-rw-r--r-- 1 bazilxp admin 466908 Jan 5 18:41 libmbedtls.10.dylib
-rw-r--r-- 1 bazilxp admin 210660 Jan 5 18:41 libmbedx509.0.dylib
-rw-r--r-- 1 bazilxp admin 24720 Jan 5 18:41 libogg.0.dylib
-rw-r--r-- 1 bazilxp admin 1515192 Jan 5 18:41 libopenal.1.dylib
-rw-r--r-- 1 bazilxp admin 177300 Jan 5 18:41 libpng16.16.dylib
-rw-r--r-- 1 bazilxp admin 2319772 Jan 5 18:41 libturbojpeg.0.dylib
-rw-r--r-- 1 bazilxp admin 136648 Jan 5 18:41 libuv.1.dylib
-rw-r--r-- 1 bazilxp admin 158180 Jan 5 18:41 libvorbis.0.dylib
-rw-r--r-- 1 bazilxp admin 34684 Jan 5 18:41 libvorbisfile.3.dylib

-rwxrwxrwx 1 bazilxp admin 39968 Jan 27 21:58 mysql.hdll
-rwxrwxrwx 1 bazilxp admin 48000 Jan 27 21:58 openal.hdll
-rw-r--r-- 1 bazilxp admin 925404285 Jan 27 22:03 res.pak
drwxr-xr-x 20 bazilxp admin 640 Dec 6 17:23 save
-rwxrwxrwx 1 bazilxp admin 56476 Jan 27 21:58 sdl.hdll
-rwxr-xr-x 1 bazilxp admin 25972 Jan 5 18:41 ssl.hdll
-rwxrwxrwx 1 bazilxp admin 10128 Jan 27 21:57 ui.hdll
-rwxrwxrwx 1 bazilxp admin 15980 Jan 27 21:58 uv.hdll
Post edited January 27, 2021 by bazilxp
I've also tried this way of fixing the game, and it works.

At first it did not, but by running /Applications/Dead\ Cells/deadcells from the terminal, you can see which libraries it cannot load.
These libraries can be restored from a backup or Time Machine from before the update.
I had to restore one extra file: fmt.hdll
After that, I could run Dead Cells with the Fatal Fals DLC.

Thanks for the tip, @bazilxp!
Thanks for the replies and the workaround.
Looks like Motion Twin are onto it. This forum won't let me post a link to Motion Twin's twitter reply to someone else having that error. The post was dated yesterday, so looking forward to a fix soon.
Looks like the fix is now on GOG, I just updated it and it works.
Post edited January 28, 2021 by PSi_AU
avatar
PSi_AU: Looks like the fix is now on GOG, I just updated it and it works.
It does not work on intel Mac:) need hotfix it :)